Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 163007 - After session KDE icons (System, Home, and Trash) are left in GNOME desktop
Summary: After session KDE icons (System, Home, and Trash) are left in GNOME desktop
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: switchdesk
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact:
URL:
Whiteboard:
: 107009 169297 (view as bug list)
Depends On:
Blocks: 221245
TreeView+ depends on / blocked
 
Reported: 2005-07-12 07:28 UTC by Kam Leo
Modified: 2008-03-10 17:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-03-10 17:32:58 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 343481 0 None None None Never

Description Kam Leo 2005-07-12 07:28:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I'm not certain whether this problem should be filed against KDE or switchdesk; however, here's problem I am encountering:

Switching sessions from Gnome to KDE and back to Gnome result in KDE icons (System, Home, and Trash) appearing in the Gnome desktop.

The following files are placed in the ~/Desktop directory: 

  Home.desktop
  System.desktop
  Trash.desktop

Expectation is that these files would be stored in the .kde or .local directory.

Version-Release number of selected component (if applicable):
switchdesk-4.0.6-3

How reproducible:
Always

Steps to Reproduce:
1.  From terminal create new user
2.  Log in as new user using default switchdesk gui settings
3.  Log out
4.  Select KDE session from switchdesk gui
5.  Log in as new user
6.  Reply no to default desktop question
7.  Log out
8.  Select Gnome session from switchdesk gui
9.  Log in as new user
  

Actual Results:  Six icons appear on Gnome desktop.

Gnome icons: Computer, new_user's Home, Trash
KDE icons:   System, Home, Trash


Expected Results:  Only Gnome icons should have appeared.

Additional info:

Comment 1 Than Ngo 2005-07-19 16:36:38 UTC
it's a bug in nautilus, it should hide the KDE icons (System, Home, Trash)

Comment 2 A S Alam 2006-02-24 06:50:10 UTC
This bug is present in FC5tes3 also, 
Only Trash Icon (from KDE) available on Gnome Desktop

Comment 3 Kam Leo 2006-07-23 07:18:56 UTC
Problem is still occuring in the released version of FC5. 


Comment 4 Alexander Larsson 2006-08-22 12:28:46 UTC
I'm not sure why nautilus should go through special cases for kde files.
Honoring OnlyDisplayIn or something like that seems like a bad idea for a file
manager (although good in the menus) as those files would just disappear in e.g.
/usr/share/applications.


Comment 5 Kam Leo 2006-08-23 03:43:50 UTC
(In reply to comment #4)
> I'm not sure why nautilus should go through special cases for kde files.
> Honoring OnlyDisplayIn or something like that seems like a bad idea for a file
> manager (although good in the menus) as those files would just disappear in e.g.
> /usr/share/applications.
> 

It should not be nautilus's task. Since the bundled display managers are GDM or
KDM perhaps the developer(s) of those two utilities could add a little code to
hide KDE icons when a user selects a different desktop.

Comment 6 Alexander Larsson 2006-09-04 14:08:56 UTC
*** Bug 107009 has been marked as a duplicate of this bug. ***

Comment 7 Alexander Larsson 2006-09-04 15:22:35 UTC
*** Bug 169297 has been marked as a duplicate of this bug. ***

Comment 8 Alexander Larsson 2007-01-11 11:31:46 UTC
I guess switchdeskt could do that.


Comment 9 Than Ngo 2008-03-10 17:32:58 UTC
I'm not sure it's a switchdesk's task. switchdesk is only used to switch the 
desktop without changing the current desktop setting, in this case removing 
Desktop files isn't good idea!

When you start KDE, kdesktop creates Home/Trash/System desktop files in 
$HOME/Desktop that are needed for KDE enviroment.

IMO It's not really a bug in KDE but rather an KDesktop design issue that 
causes the conflict with nautilus. This issue can't be fixed without massive 
changes in KDE. 

The KDE4 won't have this problem anymore since it uses new plasma, new 
replacement for kdestop.



Note You need to log in before you can comment on or make changes to this bug.