Bug 163026 - FTP-Login fails with proftpd
FTP-Login fails with proftpd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: proftpd (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-12 07:14 EDT by Oliver Voelker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 04:51:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages pam-failures (830 bytes, text/plain)
2005-07-12 07:16 EDT, Oliver Voelker
no flags Details
correct file /etc/pam.d/ftp (662 bytes, text/plain)
2005-07-12 07:17 EDT, Oliver Voelker
no flags Details
pam configuration for vsftpd (300 bytes, text/plain)
2005-07-13 04:45 EDT, Tomas Mraz
no flags Details

  None (edit)
Description Oliver Voelker 2005-07-12 07:14:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The login via FTP fails on x86_64 systems because of a wrong path in /etc/pam.d/ftp
It links to the 32-bit versions of the pam-libraries.

The result in /var/log/messages is attached.
Changing the path in /etc/pam.d/ftp enabled correct login to the FTP-Service.

Version-Release number of selected component (if applicable):
pam-0.79--8

How reproducible:
Always

Steps to Reproduce:
1. Install proftpd + pam on a x86_64 system
2. login failes
  

Actual Results:  login fails

Expected Results:  succesful login

Additional info:
Comment 1 Oliver Voelker 2005-07-12 07:16:19 EDT
Created attachment 116648 [details]
/var/log/messages pam-failures
Comment 2 Oliver Voelker 2005-07-12 07:17:22 EDT
Created attachment 116649 [details]
correct file /etc/pam.d/ftp
Comment 3 Tomas Mraz 2005-07-13 04:44:14 EDT
The /etc/pam.d/ftp is owned by the proftpd package not pam.

Even your provided ftp file is not right. The correct solution is to remove the
paths completely leaving only the module filenames there. However the file is
wrong also by other means - it uses pam_pwdb but this is not setup by default in
Fedora Core so if you want to use system accounts for logging into the ftp the
/etc/pam.d/ftp should be changed similarly to the /etc/pam.d/vsftpd of the
vsftpd daemon.
Comment 4 Tomas Mraz 2005-07-13 04:45:21 EDT
Created attachment 116694 [details]
pam configuration for vsftpd
Comment 5 Matthias Saou 2005-07-13 05:24:30 EDT
Looks like the pam file provided inside the proftpd sources is 64bit
incompatible and got obsolete by now too. I'll test a new proftpd build with a
pam.d file based on the vsftpd one (basically the same, but using the
/etc/ftpusers it always has), and if all goes well, I'll release a new Extras build.
Comment 6 Matthias Saou 2005-08-02 11:09:11 EDT
The fixed packages are waiting to be signed and be pushed :

http://buildsys.fedoraproject.org/logs/4/305-proftpd-1.2.10-6.fc4/

Things now work for me, but I've only been able to test on i386, so confirmation
that the new pam.d file makes things work on x86_64 would be nice.
Comment 7 Oliver Voelker 2005-08-03 04:16:46 EDT
the fixes are working on x86_64

Note You need to log in before you can comment on or make changes to this bug.