Bug 163027 - FC4's perl-DBD-Pg fails to detect PostgreSQL version for PostgreSQL 8
FC4's perl-DBD-Pg fails to detect PostgreSQL version for PostgreSQL 8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-DBD-Pg (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-12 07:47 EDT by Emmanuel Seyman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 11:08:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Updates perl-DBD-Pg's spec file to v1.43 (647 bytes, patch)
2005-07-12 07:47 EDT, Emmanuel Seyman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 300154 None None None Never

  None (edit)
Description Emmanuel Seyman 2005-07-12 07:47:30 EDT
Description of problem:
When installing the current CVS version of Bugzilla on FC4, selecting postgresql
as the database and running the checksetup script to configure it ends with:

Checking for      PostgreSQL (v7.03.0000)
Your PostgreSQL v00.00.0000 is too old.
   Bugzilla requires version 7.03.0000 or later of PostgreSQL.
   Please download and install a newer version.

This is due to a bug in DBD-Pg which gives the wrong version numbre of
postgresql. It's fixed upstream in 1.43

Version-Release number of selected component (if applicable):
1.41-2

How reproducible:
always

Steps to Reproduce:
1. checkout current CVS version of Bugzilla
2. run checksetup and edit localconfig to use postgresql as a database
3. run checksetup a second time
  
Actual results:
Checksetup ends with:

Checking for      PostgreSQL (v7.03.0000)
Your PostgreSQL v00.00.0000 is too old.
   Bugzilla requires version 7.03.0000 or later of PostgreSQL.
   Please download and install a newer version.

Expected results:
The correct version of postgresql should be reported (v08.00.0300 in FC4's case)

Additional info:
I've updated the .spec file to build DBD-Pg 1.43. Diff attached.
Comment 1 Emmanuel Seyman 2005-07-12 07:47:31 EDT
Created attachment 116650 [details]
Updates perl-DBD-Pg's spec file to v1.43
Comment 2 Jose Pedro Oliveira 2005-07-27 22:49:55 EDT
Seyman,

perl-DBD-Pg 1.43 is in rawhide since the end of June and it is expected to be
released as an FC4 update (see bugzilla entry 156840).

Can you the rawhide version with bugzilla and post the results here?

Thanks in advance,
jpo
Comment 3 Emmanuel Seyman 2005-07-28 08:33:40 EDT
(In reply to comment #2)
>
> Seyman,

Ugh. Emmanuel, please.

> Can you the rawhide version with bugzilla and post the results here?

Installed. This fixes all the problems I had with 1.41

Note You need to log in before you can comment on or make changes to this bug.