Bug 163060 - default printer is wrong
default printer is wrong
Product: Fedora
Classification: Fedora
Component: libgnomeprintui (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Depends On:
  Show dependency treegraph
Reported: 2005-07-12 13:40 EDT by Need Real Name
Modified: 2008-05-06 11:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 11:30:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot of printer queue showing invalid printer (35.16 KB, image/png)
2005-07-12 16:06 EDT, Need Real Name
no flags Details
browsed queues (29.10 KB, image/png)
2005-07-12 16:07 EDT, Need Real Name
no flags Details
browsed queues (33.66 KB, image/png)
2005-07-12 16:11 EDT, Need Real Name
no flags Details
evince print dialogue showing wrong default printer (39.15 KB, image/png)
2005-07-12 16:13 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2005-07-12 13:40:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.6.1

Description of problem:
The printer I select as default is not the default printer.

Instead, the apps are defaulting to either a printer in a browsed print queue, or to "generic postscript document". Neither are the default printer according to the printer config tool.

Additionally, there should be a way to clear the browsed print queue.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Additional info:
Comment 1 Tim Waugh 2005-07-12 15:16:36 EDT
You need to fill in the "Steps to reproduce" section, or else I don't know how
you are setting the default queue, or which applications you are using, or what
you mean by "clear the browsed print queue" (which is automatically managed all
the time).
Comment 2 Need Real Name 2005-07-12 16:06:10 EDT
Created attachment 116680 [details]
screenshot of printer queue showing invalid printer

How to reproduce.

This is an HP printer using the special hplip driver.
Originally I tried to setup the printer using the printconf-gui, but that
The printer you see labelled PSC1610 in the screenshot is that printer. If I
print to it, nothing happens.

Since I needed to print something pretty urgently, I removed that printer.
I then added a new printer, this time using the cups web interface. It worked.
Comment 3 Need Real Name 2005-07-12 16:07:52 EDT
Created attachment 116682 [details]
browsed queues

Here is a list of browsed queues and valid printers.
My current printer, the one that works, is not shown.
Comment 4 Need Real Name 2005-07-12 16:11:12 EDT
Created attachment 116683 [details]
browsed queues

Here is a list of browsed queues and valid printers.
The printer in the browsed queue cannot be deleted, and doesn't work.
Comment 5 Need Real Name 2005-07-12 16:13:33 EDT
Created attachment 116684 [details]
evince print dialogue showing wrong default printer

This is the print dialogue for evince showing the wrong default printer.
I get the same dialogue in gedit.

Note that the default printer in attachment 116683 [details] shows that psc-1600-series-1
should be the default printer.
Comment 6 Need Real Name 2005-07-12 16:15:44 EDT
The old, unworking printer was removed using printconf-gui.
The new, working printer was made the default using printconf-gui.

Apologies for the bugspam.
Comment 7 Tim Waugh 2005-07-26 06:43:08 EDT
Two issues here:

* browsed printer doesn't work
  This is a configuration problem on your site.

* print dialog doesn't highlight specified default queue
  This is a libgnomeprintui bug I think.

Comment 8 Christian Iseli 2007-01-19 19:13:57 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 9 Need Real Name 2007-02-27 10:40:47 EST
It works better, but restarting the application that uses the printer is required.
Comment 10 Need Real Name 2007-02-28 08:55:13 EST
Adding some text to make bug change to ASSIGNED again.
If this doesn't work, please can otaylor change the status?
Comment 11 Bug Zapper 2008-04-03 21:58:49 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 12 Bug Zapper 2008-05-06 11:30:05 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.