Bug 163081 - Driver not found for SiS 190/191 MAC + Realtek RTL8201CL 10/100 LAN PHY lan card
Driver not found for SiS 190/191 MAC + Realtek RTL8201CL 10/100 LAN PHY lan card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
: 163084 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-12 15:28 EDT by vishal
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-15 13:34:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vishal 2005-07-12 15:28:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
this lan card is not there in the lan card list so network doesn't work on os. And also i am not able to do the installation through ftp. It gives error unable to find device of this type needed for this installation type.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start installation
2.chose method as ftp
3.error comes
  

Expected Results:  it should contain that lan acrdon it's list

Additional info:
Comment 1 Harald Hoyer 2005-07-13 03:24:22 EDT
*** Bug 163084 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2005-07-15 16:25:45 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Dave Jones 2005-07-15 19:20:14 EDT
(ignore the previous comment, it happened as part of a mass-update).

Can you include the output of lspci on this box please ?

Note, that as there'll not be a re-release of the FC3 installation CDs, FC3 will
never support network install for this card.  We can however make sure that a)
the update kernels work with it, and b) that future releases will support it
during install time.

Thanks.
Comment 4 John W. Linville 2005-09-16 14:33:27 EDT
Closed due to lack of response.  Please re-open when the requested info 
becomes available...thanks! 
Comment 5 Louis Voo 2005-10-27 06:42:06 EDT
This bug still occurs in FC4. FC4 still can't detect this network card.
Can I report this bug in FC4?
Comment 6 John W. Linville 2005-10-27 10:38:14 EDT
Please do so, and include the output of "lspci -n" when you do...thanks! 
Comment 7 vishal 2005-11-11 23:37:18 EST
(In reply to comment #3)
> (ignore the previous comment, it happened as part of a mass-update).
> 
> Can you include the output of lspci on this box please ?

out put of lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 760/M760 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS965 [MuTIOL Media IO]
(rev 47)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound
Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS]: Unknown device 0190
00:05.0 RAID bus controller: Silicon Integrated Systems [SiS]: Unknown device
0182 (rev 01)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS]: Unknown device 000a
00:07.0 PCI bridge: Silicon Integrated Systems [SiS]: Unknown device 000a
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760
PCI/AGP VGA Display Adapter

currently i am using fc4.... net does not work on this too..... can you provide
some kernel which have it

sorry for being late
Comment 8 John W. Linville 2005-11-14 09:11:58 EST
Very strange.  That should be covered by the sis190 driver, and that driver  
appears to be enabled in the kernel build.  
  
Please post the contents of your /etc/modprobe.conf file.  You need a line in  
it that looks like this:  
 
   alias eth0 sis190 
 
Please try making that change, and rebooting.  Then, post the results 
here...thanks! 
Comment 9 vishal 2005-11-15 07:34:04 EST
sorry i have given this output in kernel in which net works... difficult to get
the output from the old kernel and posting it as net doesn't work on that.... i
hold a server on my comp so kinda not possible... The news is that New kernel
2.6.14 as this kernel in it.... so problem can be solved my updating comp to
that... that kernel also have some problem... i am going to start a new thread
for that.....
Comment 10 John W. Linville 2005-11-15 13:34:44 EST
Ah...I see...the sis190 driver is not in FC3.  Using FC4 should work for you. 
 
Good luck! 

Note You need to log in before you can comment on or make changes to this bug.