Bug 163113 - partitioning fails Attributeerror: 'NoneType' object has no attribute name
partitioning fails Attributeerror: 'NoneType' object has no attribute name
Status: CLOSED DUPLICATE of bug 161877
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-12 19:29 EDT by Evan Panagiotopoulos
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-26 00:00:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evan Panagiotopoulos 2005-07-12 19:29:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511

Description of problem:
During installation of FC4 I receive an error on my iBook. I can't save the information without a floppy. Initially i received an error saying "pvcreate failed." Now I always get a multi-line exception that points to partedUtils.py line 140, in get_partition_file_system_type 

elif

(part.get_flag(parted.PARTITION_BOOT) == 1 and AttributeError: 'NoneType' object has no attribute 'name'


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot iBook with cd FC4 #1
2. Choose either text or graphical intallation
3. Any choice of installation and/partitioning
  

Actual Results:  A popup window lists the exception

Additional info:
Comment 1 Chris Lumens 2005-07-13 09:54:35 EDT
Please post the full traceback message you are getting.
Comment 2 Cedric Buot de l'Epine 2005-07-22 12:36:50 EDT
Same problem for me.
So here's the traceback.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1160, in ?
    intf.run(id, dispatch)
  File "/usr/lib/anaconda/text.py", line 496,
in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line
174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line
242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/partitioning.py",
line 54, in partitionObjectsInitialize
    partitions.setFromDisk(diskset)
  File "/usr/lib/anaconda/partitions.py", line
108, in setFromDisk
    ptype = 
partedUtils.get_partition_file_system_type(part)
  File "/usr/lib/anaconda/partedUtils.py", line
140, in get_partition_file_system_type
    elif (part.get_flag(parted.PARTITION_BOOT)
== 1 and
AttributeError: 'NoneType' object has no 
attribute 'name'

No idea of how to copy/paste, so I hope I didn't make too many typos.

My "parted /dev/hda print": 
Disk geometry for /dev/hda: 0.000-9590.273 megabytes
Disk label type: mac
Minor    Start       End     Filesystem  Name                  Flags
1          0.000      0.031              Apple                 
2          0.031      0.058              Macintosh             
3          0.059      0.085              Macintosh             
4          0.086      0.113              Macintosh             
5          0.113      0.140              Macintosh             
6          0.141      0.390              Macintosh             
7          0.391      0.640              Macintosh             
8          0.641      0.890              Patch Partition       
9          0.891      1.890              boot                  boot
10         1.891   4280.890              root                  root
11      4280.891   4792.890              swap                  swap
12      4924.047   9590.265  hfs+        Apple_HFS_Untitled_3  
Information: Don't forget to update /etc/fstab, if necessary.  

I tried to name the parts 9 and 10 from "unknown" to boot/root the the problem
seems to come from the swap.
Comment 3 Paul Nasrat 2005-07-22 12:44:37 EDT
What created the partition table above? This looks completely wrong. Please
delete the created partition and let anaconda partition in the free space.

Or else you'll need an Apple_Bootstrap partition with the boot flag (this is NOT
/boot it is something different). No other flags should be set on the linux
partitions unless it is lvm.
Comment 4 Jeremy Katz 2005-07-26 00:00:38 EDT

*** This bug has been marked as a duplicate of 161877 ***
Comment 5 Cedric Buot de l'Epine 2005-08-23 07:16:08 EDT
Anaconda did this before a first crash.
So I've "cat /dev/zero >> /dev/hda" and re-install macosx and all.
I then just had the same problem.
The first anaconda crash is reproductible when installing FC4 in french and text
mode.
re-wipe/re-re-installing the all stuff in english just worked fine.

Note You need to log in before you can comment on or make changes to this bug.