Bug 163135 - ps2pdf crash with "Error: /invalidfont in --show--"
ps2pdf crash with "Error: /invalidfont in --show--"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ghostscript (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
ftp://ftp.it.lt/pub/upload/gs_bug/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-13 07:04 EDT by Modestas Mockus
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:58:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"inv_0-5.ps" converts ok to "inv_0-5.pdf" (822.90 KB, application/octet-stream)
2005-07-13 07:07 EDT, Modestas Mockus
no flags Details
"inv_0-5.ps" converts ok to "inv_0-5.pdf" (312.18 KB, application/octet-stream)
2005-07-13 07:08 EDT, Modestas Mockus
no flags Details
this converts with error (334.77 KB, application/octet-stream)
2005-07-13 07:09 EDT, Modestas Mockus
no flags Details
converted pdf after error (56.02 KB, application/octet-stream)
2005-07-13 07:10 EDT, Modestas Mockus
no flags Details
convert script (210 bytes, text/plain)
2005-07-13 07:11 EDT, Modestas Mockus
no flags Details

  None (edit)
Description Modestas Mockus 2005-07-13 07:04:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Problem description:
within Oracle application 11.5.10  on RHEL3 I'm printing invoice to PostScript output using IXLIB (Unicode arial.TTF ant times.ttf fonts)
after that i'm converting PostScript to PDF by command:

gs -q -dSAFER -dNOPAUSE -dBATCH -sDEVICE#pdfwrite -sPAPERSIZE#a4 \
-sOutputFile#invoice.pdf -dCompatibilityLevel#1.4 -c .setpdfwrite -f invoice.ps

PostScript output is ok, i can view it with command >GS invoice.pdf
The ps to pdf converting is working ok if i have PS file containing 1-7 invoices. (1 invoice: 1-2 pages)
But converting is crashing if file contains 8-50  invoices with error.
Excample:
Let's say I did printed 30 invoices to PS, convert to pdf and resulting PDF after crashing contains only 3 invoices.
There is no faulty invoice, because i can print invoices No.:  0-20, or No. 5-25, they will print ok, but No. 0-25 will crash

I can convert invoice.ps to pdf with GhostScript 8.51 for Windows:
if my invoice.ps contained 180 invoices, converted PDF will also contain 180 invoices.

atatached files:
1. "inv_0-5.ps" converts ok to "inv_0-5.pdf"
2. "inv_0-30.ps" converts to "inv_0-30.pdf" with crash and rezulting PDF contains only invoices 0-3
3. makepdf.sh (convert script)



Version-Release number of selected component (if applicable):
ghostscript-7.05-32.1.8

How reproducible:
Always

Steps to Reproduce:
1. made invoice.ps file from Oracle business suite
2. run script:
./makepdf.sh inv_0-30.ps
3. got error
  

Actual Results:  scripts ends with error and I'm getting pdf witch contains only some(3 or more) of pages, existing in PostScript file.
Error: /invalidfont in --show--
Operand stack:
   --nostringval--   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1055/1123(ro)(G)--   --dict:0/20(G)--   --dict:198/200(L)--
Current allocation mode is local
Last OS error: 2
Current file position is 137433
GNU Ghostscript 7.05: Unrecoverable error, exit code 1


Expected Results:  i'm expeting pdf document eith 30 pages
with GhostScript 8.51 for Windows converting is successful.

Additional info:

we have 5 RHEL3 servers, this error is on all of them.
I tried this on fedora core 4 (dont remember gs version) - the same error.
Comment 1 Modestas Mockus 2005-07-13 07:07:54 EDT
Created attachment 116695 [details]
"inv_0-5.ps" converts ok to "inv_0-5.pdf"
Comment 2 Modestas Mockus 2005-07-13 07:08:32 EDT
Created attachment 116696 [details]
"inv_0-5.ps" converts ok to "inv_0-5.pdf"
Comment 3 Modestas Mockus 2005-07-13 07:09:49 EDT
Created attachment 116697 [details]
this converts with error

""inv_0-30.ps" converts to "inv_0-30.pdf" with crash and rezulting PDF contains
only invoices 0-3
Comment 4 Modestas Mockus 2005-07-13 07:10:43 EDT
Created attachment 116698 [details]
converted pdf after error

""inv_0-30.ps" converts to "inv_0-30.pdf" with crash and rezulting PDF contains
only invoices 0-3
Comment 5 Modestas Mockus 2005-07-13 07:11:52 EDT
Created attachment 116699 [details]
convert script
Comment 8 RHEL Product and Program Management 2007-10-19 14:58:09 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.