Bug 163174 - Default mode appears to be 0660 since 051, not 0600
Default mode appears to be 0660 since 051, not 0600
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-13 14:47 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 08:24:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
For reference: upstreamed fix for default mode docs (1.76 KB, patch)
2005-07-13 14:47 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2005-07-13 14:47:21 EDT
The default mode of device nodes created by udev appears to be 0660 since udev  
051, not 0600 like the comments in 50-udev.rules shipped in FC4 and later 
says. 
 
I reported this upstream and sent the attached patch there, but I'm reporting 
it here as well because the FC package is using a "private" 50-udev.rules, not 
the upstream redhat/udev.rules one. 
 
Additionally, if the default really is 0660 nowadays, the shipped 
50-udev.rules could be cleaned up quite a bit.
Comment 1 Ville Skyttä 2005-07-13 14:47:22 EDT
Created attachment 116715 [details]
For reference: upstreamed fix for default mode docs
Comment 2 Harald Hoyer 2006-02-15 08:24:16 EST
put mode back to 0600 to keep secure settings.

Note You need to log in before you can comment on or make changes to this bug.