Bug 163243 - missing buildrequires , at least libgnomeui-devel
missing buildrequires , at least libgnomeui-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-14 09:40 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 21:57:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2005-07-14 09:40:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
rebuilding evince in a minimal chroot (mock) fails:
checking for gtk+-2.0 >= 2.4.0... yes
checking LIBEVPRIVATE_CFLAGS... -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2/config -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  
checking LIBEVPRIVATE_LIBS... -L/usr/X11R6/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangocairo-1.0 -lpangox-1.0 -lpangoft2-1.0 -lfreetype -lz -lcairo -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lfontconfig -lpixman -lXrender -lX11 -lXext -lpng12  
checking for gtk+-2.0 >= 2.4.0 libgnomeui-2.0 >= 2.4.0... Package libgnomeui-2.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `libgnomeui-2.0.pc' to the PKG_CONFIG_PATH environment variable No package 'libgnomeui-2.0' found
configure: error: Library requirements (gtk+-2.0 >= 2.4.0 libgnomeui-2.0 >= 2.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
error: Bad exit status from /var/tmp/rpm-tmp.934 (%build)

Version-Release number of selected component (if applicable):
evince-0.3.1-2

How reproducible:
Always

Steps to Reproduce:
1. install mock
2. run mock -r fedora-development-i386-core.cfg evince-0.3.1-2.src.rpm
3. check output
  

Additional info:
Comment 1 Marc Maurer 2005-09-12 13:32:56 EDT
gnome-keyring-1 it seems is missing:

[root@pinohuis ~]# pkg-config --libs libgnomeui-2.0
Package gnome-keyring-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gnome-keyring-1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'gnome-keyring-1', required by 'libgnomeui', not found

This blocks abiword from building too.
Comment 2 Marc Maurer 2005-09-12 13:34:43 EDT
ok, ignore that...i thought this was a bug against libgnomeui.. /me blind
Comment 3 Matthias Clasen 2006-08-28 21:57:20 EDT
BR have been largely fixed up after the brew switchover.

Note You need to log in before you can comment on or make changes to this bug.