Bug 163373 - RHEL4 installation fails: megaraid driver cannot see logical drives with HP NetRAID-1M
RHEL4 installation fails: megaraid driver cannot see logical drives with HP N...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-15 12:12 EDT by Yavor Trapkov
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 18:07:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yavor Trapkov 2005-07-15 12:12:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When I install RHEL4 on HP LP1000r/LP2000r, the installation can't recognize the HP NetRAID-1M logical RAID drives

Megaraid drivers seem unable to recognize perfectly valid logical RAID
drives on install

RHEL3 works fine with the same hardware

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.HP LP1000r/HP LP2000r (NetRAID-1M)
2.Insert RHEL4 release install disk1 and attempt to install
3.the istallation failes to recognizes valid logical RAID drives
  

Actual Results:  Can't install/upgrade to RHEL 4 on HP LP1000r/HP LP2000r

Expected Results:  to be able to upgrade existing RHEL 3

Additional info:
Comment 1 Tom Coughlan 2005-07-25 11:12:58 EDT
When LSI Logic went from the megaraid2 driver in 2.4 to the megaraid_mbox driver
in 2.6, they dropped support for certain adapters. I believe the NetRAID-1M is
one of the ones that was dropped. If you post the output of lspci from your RHEL
3 system I can confirm.

Comment 2 Yavor Trapkov 2005-07-27 05:07:17 EDT
here is the output from lspci

01:05.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1010 Ultra3 SCSI
Adapter (rev 01)
01:05.1 SCSI storage controller: LSI Logic / Symbios Logic 53c1010 Ultra3 SCSI
Adapter (rev 01)
02:01.0 SCSI storage controller: QLogic Corp. ISP12160 Dual Channel Ultra3 SCSI
Processor (rev 06)
03:00.0 RAID bus controller: American Megatrends Inc. MegaRAID (rev 20)

it's probably the case what you write .. they don't support certain adapters.
I found more info on internet and it seems a module megaraid_legacy should be
included in the latest 2.6.12 (I googled "megaraid_legacy")
Could this be included in the supported RHEL4 kernels
The problem is that there are many HP, Dell servers that use the "now
unsupported" by RHEL4 scci/raid adapter.
Comment 3 Tom Coughlan 2005-07-28 18:07:05 EDT
From the RHEL 4 release notes (for original release, and U1):

http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/release-notes/as-x86/RELEASE-NOTES-U1-x86-en.html

    * The kernel shipped with Red Hat Enterprise Linux 4 Update 1 includes the
new megaraid_mbox driver from LSI Logic, which replaces the megaraid driver. The
megaraid_mbox driver has an improved design, is compatible with the 2.6 kernel,
and includes support for the latest hardware. However, megaraid_mbox does not
support some of the older hardware that was supported by the megaraid driver.

      Adapters with the following PCI vendor ID and device ID pairs are not
supported by the megaraid_mbox driver:


vendor, device

0x101E, 0x9010
0x101E, 0x9060
0x8086, 0x1960

      The lspci -n command can be used to display the IDs for adapters installed
in a particular machine. Products with these IDs are known by (but not limited
to) the following model names: 

    *Broadcom 5820
    *Dell PERC (dual-channel fast/wide SCSI) RAID controller
    *Dell PERC2/SC (single-channel Ultra SCSI) RAID controller
    *Dell PERC2/DC (dual-channel Ultra SCSI) RAID controller
    *Dell CERC (four-channel ATA/100) RAID controller
    *DRAC 1
    *MegaRAID 428
    *MegaRAID 466
    *MegaRAID Express 500
    *HP NetRAID 3Si and 1M 

Note

Both Dell and LSI Logic have indicated that they no longer support these models
in the 2.6 kernel. As a result, these adapters are no longer supported in Red
Hat Enterprise Linux 4 Update 1.

======

I agree, this stinks, but there is not much we can do. The legacy driver and the
current driver have overlapping support, so we can not turn both on. The legacy
driver has also not received any recent maintenance.  
Comment 4 Yavor Trapkov 2005-08-02 04:49:54 EDT
Well, I'd like to have one last comment on this:

- could you check/confirm that the legacy driver is part of the last 2.6.12-
kernels, can this driver be included as a module, so users who still have these
"old" cards can manually load and then install rhel4

- as the driver is still part of the rhel3, it should be supported be RedHat, right?

- it's just that there are many "enterprise" users of RedHat who will suffer
problems without this, there are many HP, Dell servers that still have long
production live and they can't now be used with RHEL4

Note You need to log in before you can comment on or make changes to this bug.