Bug 163438 - Updated udev package required to create symlinks
Updated udev package required to create symlinks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On: 158570
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-16 12:43 EDT by Robert Nichols
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 03:46:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for udev-039-10.FC3.7.src.rp (1.99 KB, patch)
2005-08-22 12:07 EDT, Alan Stern
no flags Details | Diff

  None (edit)
Description Robert Nichols 2005-07-16 12:43:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
Rules to create symlinks in /dev no longer work with this kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. On a system with a Prolific 2303 USB-to-serial converter installed, create /etc/udev/rules.d/10-local.rules containing the line:

   BUS="usb", SYSFS{idVendor}="067b", SYSFS{idProduct)="2303", SYMLINK="UPS"

2. Reboot.

  

Actual Results:  There is no symlink /dev/UPS .

Expected Results:  There should be a symlink /dev/UPS -> ttyUSB0 .

Additional info:

The problem is a missing dependency on an updated "udev" package.  See

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=158570

and

  http://www.ussg.iu.edu/hypermail/linux/kernel/0505.2/1368.html
Comment 1 Dave Jones 2005-07-29 15:35:04 EDT
Harald, let me know the version of the fixed package, and I'll add this to the
dependancies in the next update (which should be sometime next week).
Comment 2 Harald Hoyer 2005-08-02 11:08:59 EDT
well, Dave, udev-058 would require hotplug from FC4, which would require
initscripts from FC4, which would require SysVinit from FC4...
Comment 3 Bill Nottingham 2005-08-03 20:44:23 EDT
I thought it was the FC5 devel udev that is the one dragging in the world; the
FC4 udev at least doesn't have obvious requires for newer stuff.
Comment 4 Harald Hoyer 2005-08-04 04:55:43 EDT
without the hotplug from FC4, I do not get symlinks with udev...
Comment 5 Bill Nottingham 2005-08-04 11:19:24 EDT
How would hotplug affect symlinks with udev? I'm not sure where it would even
get in the way.
Comment 7 Alan Stern 2005-08-22 11:19:45 EDT
The problem is that udev-039 isn't following the chain of parent directories
when looking for sysfs attributes.  It reads the directories corresponding to
the class device and the actual device but doesn't go up.  Probably because (as
noted in the release notes for udev-058) sysfs no longer supplies the useless
"detach_state" file.

Here's an example from my system:

$ udevinfo -a -p /sys/block/sr0

udevinfo starts with the device the node belongs to and then walks up the
device chain, to print for every device found, all possibly useful attributes
in the udev key format.
Only attributes within one device section may be used together in one rule,
to match the device for which the node will be created.

  looking at class device '/sys/block/sr0':
    SYSFS{dev}="11:0"
    SYSFS{range}="1"
    SYSFS{removable}="1"
    SYSFS{size}="2097151"
    SYSFS{stat}="       0        0        0        0        0        0        0
       0        0        0        0"

follow the class device's "device"
  looking at the device chain at
'/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2:2.0/host0/target0:0:0/0:0:0:0':
    BUS="scsi"
    ID="0:0:0:0"
    SYSFS{device_blocked}="0"
    SYSFS{iocounterbits}="32"
    SYSFS{iodone_cnt}="0x3"
    SYSFS{ioerr_cnt}="0x0"
    SYSFS{iorequest_cnt}="0x4"
    SYSFS{max_sectors}="256"
    SYSFS{model}="CD-RW GCE-8160B "
    SYSFS{queue_depth}="1"
    SYSFS{queue_type}="none"
    SYSFS{rev}="1.02"
    SYSFS{scsi_level}="3"
    SYSFS{state}="running"
    SYSFS{timeout}="0"
    SYSFS{type}="5"
    SYSFS{vendor}="HL-DT-ST"

It stops there, without going on to examine directories like
/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2.   That's the reason the symlinks
are getting set up -- the rules never match because they don't find the
attributes they're supposed to match against.
Comment 8 Alan Stern 2005-08-22 12:07:31 EDT
Created attachment 117973 [details]
Patch for udev-039-10.FC3.7.src.rp

This patch for the source RPM fixes the problem.  It replaces code in the
udev-039 source with the corresponding code from udev-068.
Comment 9 Alan Stern 2005-10-06 12:02:24 EDT
Why hasn't there been any progress on this bug?  Considering that I posted a fix
over a month ago, it's surprising that nothing at all has happened.
Comment 10 Fedora Update System 2005-10-07 11:52:44 EDT
From User-Agent: XML-RPC

udev-039-10.FC3.8 has been pushed for FC3, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 11 Jason Heiss 2005-10-09 23:22:59 EDT
That update to udev seems to have fixed things for me.  Thanks.

Jason

(In reply to comment #10)
> From User-Agent: XML-RPC
> 
> udev-039-10.FC3.8 has been pushed for FC3, which should resolve this issue.  If these problems are 
still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.