Bug 163492 - XMMS crashes (no hanging) on add directory if contains a filename is without .mp3 extension
XMMS crashes (no hanging) on add directory if contains a filename is without ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-18 06:51 EDT by Anil Kumar Sharma
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-01 10:09:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anil Kumar Sharma 2005-07-18 06:51:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
XMMS crashes instantly (no hanging) if add directory to populate playlist is chooen if and only if one of the file in directory (tree) being added does not have .mp3 extension on filename.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.12-1.1387_FC4.i686.

How reproducible:
Always

Steps to Reproduce:
1.open xmms clear playlist (or haveit as it is)
2.add directory to playlist.  navigate to the desired direcory. (directory must have at least one mp3 file named without .mp3 extension
3. press ok to accept the directory and it crashes.
  

Actual Results:  XMMS crashes system and other application keeps working normal.

Expected Results:  playlist should be renewed with additional songs to be selected for play or further funactions.

Additional info:

UI = kde
motherboard Intel D865GBF with onboard 5.1 channel audio.
5.1 channel drives (speakers set)
Comment 1 Anil Kumar Sharma 2005-07-18 06:54:35 EDT
Actual Results:  XMMS crashes. whereas system and other application keeps 
working normal.

Comment 2 John (J5) Palmieri 2005-07-18 13:40:54 EDT
xmms is in extras now.  Assigning there.
Comment 3 Michael Schwendt 2005-07-18 16:57:54 EDT
Cannot reproduce if following the "Steps to reproduce".
Comment 4 Anil Kumar Sharma 2005-07-19 08:48:00 EDT
(In reply to comment #3)
> Cannot reproduce if following the "Steps to reproduce".

Thanks for confirming.
Is there any check I may do at my end? Thanks.
Comment 5 Michael Schwendt 2005-07-19 09:28:50 EDT
You could provide a backtrace of when the crash occurs:
http://fedoraproject.org/wiki/StackTraces

You could query your RPM database:  rpm -qa 'xmms*'

You could try to reduce your files to a reproducible test-case, so it can be
examined whether file names or content cause the crash. Might be a buffer
overflow in a plugin, triggered by a specific mp3 file in your directory.
Comment 6 Anil Kumar Sharma 2005-07-20 02:25:43 EDT
(In reply to comment #5)

Thanks, Michael, 
Please bear with replies after 18-24 hours - timezone between us.

> You could provide a backtrace of when the crash occurs:
> http://fedoraproject.org/wiki/StackTraces

Will include a proper stacktrace as guided in wiki article.

> You could query your RPM database:  rpm -qa 'xmms*'
This I will attach with backtrace post.
> You could try to reduce your files to a reproducible test-case, so it can be
> examined whether file names or content cause the crash. Might be a buffer
> overflow in a plugin, triggered by a specific mp3 file in your directory.
This is already tested in three stages 
1). big tree of 12 sub-dir and 147 files
2). one directory of 12 files 
3). single file (faulty one) 
Same result. Workaround is simply to rename the file with .mp3 extension then 
it works in all 3 cases above. In fact I test loaded full collection of 3000+ 
files - It works. Crash was noted only when this typical file (on CD/hdd) was 
added to playlist.

Please wait for submission of backtrace from me.
First I have to fix another broken application - my car's hydraulics sytem for 
power steering. This is not as free as fedora but equally good. Also very 
limited help available in this case.
- just the lighter side.
Thanks
Comment 7 Matthias Saou 2006-06-30 10:31:17 EDT
Reassigning to the current maintainer (Ville).
Comment 8 Ville Skyttä 2006-07-01 10:09:21 EDT
I can't reproduce either, and since it's been almost a year without additional
feedback, closing.  If you can still reproduce in FC5+, feel free to reopen and
include the info requested in comment 5.

Note You need to log in before you can comment on or make changes to this bug.