Bug 163520 - No support for OOo 2 document extensions and some others
Summary: No support for OOo 2 document extensions and some others
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bash-completion   
(Show other bugs)
Version: rawhide
Hardware: noarch Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-18 15:22 UTC by Horst H. von Brand
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 20050712-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-31 15:37:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to /etc/bash_completion which should fix some of the brokenness (1.53 KB, patch)
2005-07-18 15:22 UTC, Horst H. von Brand
no flags Details | Diff

Description Horst H. von Brand 2005-07-18 15:22:58 UTC
Description of problem:
OpenOffice 2 documents aren't recognized

Version-Release number of selected component (if applicable):
bash-completion-20050121-1

How reproducible:
Always

Steps to Reproduce:
1. oowriter \t
2.
3.
  
Actual results:
Doesn't find something.odt

Expected results:
Complete with available files

Additional info:

Comment 1 Horst H. von Brand 2005-07-18 15:22:58 UTC
Created attachment 116873 [details]
Patch to /etc/bash_completion which should fix some of the brokenness

Comment 2 Ville Skyttä 2005-07-18 16:11:32 UTC
Thanks; some bits of your update are already included in the 2005-07-15 
version of bash-completion which I've prepared and will build/ship as soon as 
the Extras build system is ready again. 
 
I'll include the changes from your patch that weren't yet there, but a couple 
of questions: 
 
What's "sxa"?  Your patch makes oodraw complete on it, but I couldn't find 
info about sxa in oodraw or by Googling. 
 
About "vor"; if I understand correctly, it's not at all exclusively for old 
oodraw templates, but for any old StarOffice/OpenOffice.org document 
templates.  Do you think it should be added to all oo* tools? 

Comment 3 Ville Skyttä 2005-07-18 16:19:46 UTC
(Oops, a minor correction: the new version pending for build is 20050712.) 

Comment 4 Horst H. von Brand 2005-07-18 17:32:49 UTC
Oops, sxa seems to be a typo for sxd (yes, my handwriting sucks, and getting the
text out of OOo's menu for "Open file" isn't easy...). Sorry.

Besides, I'm more of an ocassional user of OOo, and a rather new one to booth.
I'm not qualified to decide on .vor

Comment 5 Horst H. von Brand 2005-07-18 17:34:52 UTC
Oh, BTW: All the .o{d,t}? formats are zip(1)ed XML, are they not? If so, they
should also go under zip.

And many thanks for your work! It is much appreciated.

Comment 6 Ville Skyttä 2005-07-18 19:59:09 UTC
Ok, thanks for the update.  Here's what I've done so far regarding this: 
 
Added stuff from your patch that wasn't in 20050712, except for "vor".  I also 
added "mml" (MathML) for oomath. 
 
Regarding the zip'd XML: yes, I believe you're right.  But they should 
obviously go under unzip, not zip... anyway, before applying that, I would 
suggest asking for upstream's opinion on this.  His email address can be found 
at the bottom of /usr/share/doc/bash-completion-*/README 

Comment 7 Ville Skyttä 2005-07-31 15:37:10 UTC
Fixed in >= 20050712-1, and all patches applied upstream as of >= 20050720-1.  


Note You need to log in before you can comment on or make changes to this bug.