Bug 163563 - OpenOffice.org Impress crashed on attempt to add a slide
OpenOffice.org Impress crashed on attempt to add a slide
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-18 18:05 EDT by Mary Ellen Foster
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-21 15:37:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Presentation that caused OOo to crash (874.56 KB, application/vnd.oasis.opendocument.presentation)
2005-07-18 18:05 EDT, Mary Ellen Foster
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 51487 None None None Never

  None (edit)
Description Mary Ellen Foster 2005-07-18 18:05:17 EDT
Created attachment 116903 [details]
Presentation that caused OOo to crash
Comment 1 Mary Ellen Foster 2005-07-18 18:05:17 EDT
Description of problem:

With the attached OpenOffice.org document, I got a crash when I tried to add a
new slide at the end. It happened once "live", and then again the first time I
tried to reproduce it, but it isn't reproducible any more. I did save the
backtrace from the second crash, and I'll put it at the end of this bug report.

My machine is running mostly FC4, but I've updated Eclipse and OpenOffice.org (+
dependencies) from rawhide.

Version-Release number of selected component (if applicable):
openoffice.org-impress-1.9.117-1.2.0.fc5

How reproducible:
The first two times I tried it, but I can't reproduce it any more now.

Steps to Reproduce:
1. Open the attached document (coming in a second)
2. Right-click in the space after slide 5 in the left column and choose "add slide"
3. New slide gets added, but OOo crashes before I can edit it
  
Actual results:
Crash

Expected results:
Not crashing

Additional info:
Here's the backtrace:
0x1c1b96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0x1c23e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0x7ad420:  + 0x420 (__kernel_sigreturn + 0x0)
0xb5cb9b0b: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xe2b0b
0xb5cd2e50: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0xfbe50
0x1f0b0e6: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1960e6
0x1f08d7c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x193d7c
(SfxDispatcher::_FillState(SfxSlotServer const&, SfxItemSet&, SfxSlot const*) +
0x54)
0x1f15030: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a0030
0x1f15284: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a0284
0x1f1542e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a042e
0x50735a2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x825a2
0x507f13e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e13e
(Timer::Timeout() + 0x10)
0x507f4b8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e4b8
0xf66fe5: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3efe5
0xf66fd0: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3efd0
(SalData::Timeout() const + 0x24)
0xde03f2: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa3f2
0xec3f06: /usr/lib/libglib-2.0.so.0 + 0x24f06
0xec23ee: /usr/lib/libglib-2.0.so.0 + 0x233ee (g_main_context_dispatch + 0x1dc)
0xec53f6: /usr/lib/libglib-2.0.so.0 + 0x263f6
0xec58d8: /usr/lib/libglib-2.0.so.0 + 0x268d8 (g_main_context_iteration + 0x66)
0xde05d5: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa5d5
0xf6dda1: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45da1
(X11SalInstance::Yield(unsigned char) + 0x29)
0x507991c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8891c
(Application::Yield() + 0x50)
0x507995a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8895a
(Application::Execute() + 0x26)
0x8065670: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1d670
(desktop::Desktop::Main() + 0x149a)
0x507ed49: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8dd49 (SVMain()
+ 0x45)
0x8060723: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18723 (sal_main +
0x47)
0x8e4de6: /lib/libc.so.6 + 0x14de6 (__libc_start_main + 0xc6)
0x8060659: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18659
(Window::RequestHelp(HelpEvent const&) + 0x31)
Comment 2 Caolan McNamara 2005-07-19 03:50:21 EDT
There'll be another update soon. There was a similiar bug which I fixed, and I'm
not seeing this in that fixed version, though it might be intermittant
Comment 3 Caolan McNamara 2005-07-21 15:37:18 EDT
Also reported as http://qa.openoffice.org/issues/show_bug.cgi?id=51487. I
haven't been able to reproduce it myself yet

Note You need to log in before you can comment on or make changes to this bug.