Bug 163610 - qlogic 2300 + sdd-module + lvm
qlogic 2300 + sdd-module + lvm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lvm (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Heinz Mauelshagen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-19 10:30 EDT by Dominik Schmid
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 06:43:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dominik Schmid 2005-07-19 10:30:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I have a hp server with two fiber channel adapters type qla2300.
The OS is RHEL 3.0 update 3.

I have installed from cd with "linux text noprobe" and loaded the cciss driver for the hp scsi raid.

Then, after the installation, i have build the qla2300 drivers from the qlogic wbsite (7.01.01 i think).
With the modules.conf option ConfigRequired=0, the luns were all successfully added.
Now i had four luns for each physical drive on the svc.

Now i installed the sdd driver from IBM and started the sdd daemon with (sdd start) -> the 8 paths were put to 2 logical vpaths (vpatha and vpathb).

I created the lvm over the vpatha (group vg_root) und copied the root filesystem to the lvm-drive on the fiber channel drives (vpatha).

/boot -> cciss partition
swap -> cciss partition
/ -> vpatha (lvm - vg_root/root)

I created a fstab.fc file with the following content:

/dev/vg_root/root       /                       ext3    defaults        1 1
/dev/cciss/c0d0p1       /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/cciss/c0d0p3       swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0

The modules.conf was modified to:

alias scsi_hostadapter1 cciss
alias scsi_hostadapter2 qla2300
alias usb-controller usb-uhci
alias usb-controller1 ehci-hcd
options ConfigRequired=0

With the mkinitrd command, i created a custom initrd file which i modified:

linuxrc:

#!/bin/nash

echo "Loading scsi_mod.o module"
insmod /lib/scsi_mod.o 
echo "Loading sd_mod.o module"
insmod /lib/sd_mod.o 
echo "Loading cciss.o module"
insmod /lib/cciss.o 
echo "Loading qla2300.o module"
insmod /lib/qla2300.o 
echo "Loading jbd.o module"
insmod /lib/jbd.o 
echo "Loading ext3.o module"
insmod /lib/ext3.o 
echo "Loading sdd-mod.o module"
insmod /lib/sdd-mod.o 
/opt/IBMsdd/bin/cfgvpath
echo "Loading lvm-mod.o module"
insmod /lib/lvm-mod.o 
echo Mounting /proc filesystem
mount -t proc /proc /proc
echo Creating block devices
mkdevices /dev
echo Scanning logical volumes
vgscan
echo Activating logical volumes
vgchange -ay
echo 0x0100 > /proc/sys/kernel/real-root-dev
echo Mounting root filesystem
mount -o rw -t ext3 /dev/vg_root/root /sysroot
tar cps /dev/IBMsdd /dev/vpath* | (cd /sysroot && tar xps)
pivot_root /sysroot /sysroot/initrd
umount /initrd/proc

filelist of the initrd-ball:

bin
bin/nash
bin/insmod
bin/modprobe
bin/vgwrapper
bin/vgscan
bin/vgchange
bin/ash
bin/awk
bin/chmod
bin/chown
bin/cp
bin/date
bin/grep
bin/ls
bin/mknod
bin/mount
bin/ps
bin/rm
bin/sed
bin/sh
bin/tar
bin/umount
dev
dev/console
dev/null
dev/ram
dev/systty
dev/tty1
dev/tty2
dev/tty3
dev/tty4
dev/vpatha
dev/vpathb
dev/sda
dev/sdb
dev/sdc
dev/sdd
dev/sde
dev/sdf
dev/sdg
dev/sdh
dev/lvm
etc
lib
lib/scsi_mod.o
lib/sd_mod.o
lib/cciss.o
lib/qla2300.o
lib/jbd.o
lib/ext3.o
lib/lvm-mod.o
lib/ld-linux.so.2
lib/libacl.so.1
lib/libattr.so.1
lib/libc.so.6
lib/libdl.so.2
lib/libm.so.6
lib/libnss_files.so.2
lib/libpcre.so.0
lib/libproc.so.2.0.17
lib/libpthread.so.0
lib/librt.so.1
lib/libtermcap.so.2
lib/sdd-mod.o
linuxrc
loopfs
proc
sbin
sysroot


NOW, my question:

I get an error while booting, but i can't get any info because of many,many ascii-text which is floating the screen.
What have i done wrong?
I think it's something at the lines:
------
echo 0x0100 > /proc/sys/kernel/real-root-dev
echo Mounting root filesystem
mount -o rw -t ext3 /dev/vg_root/root /sysroot
tar cps /dev/IBMsdd /dev/vpath* | (cd /sysroot && tar xps)
pivot_root /sysroot /sysroot/initrd
------

Has somebody a hint for me?

Regards
Dominik

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See Descripton

Additional info:
Comment 1 Suzanne Hillman 2005-07-20 14:57:02 EDT
This appears to be a support request. Therefore, you would be best off calling
888-GO-REDHAT, or going to http://www.redhat.com/support
Comment 2 Milan Broz 2006-04-25 06:43:32 EDT
This report is related to modified initrd and not bug in lvm. Please contact
support for this issue.

Note You need to log in before you can comment on or make changes to this bug.