Bug 163628 - yum update does not see versions past original one in FC3, up2date does
Summary: yum update does not see versions past original one in FC3, up2date does
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-netboot (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-19 16:58 UTC by Joe Harrington
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-19 20:08:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Harrington 2005-07-19 16:58:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.20

Description of problem:
system-config-netboot-0.1.8-1 was installed with the original install of FC3.  There have since been several updates, but the nightly yum update does not see them.  It has seen and gotten all updates to other packages.  up2date (specifically, the little red exclamation mark icon on the gnome panel, and the window that pops up when you click it) does see that the update hasn't installed.  I've tried running yum update manually, just to make sure something wasn't messed up with the cron command, but it didn't see that there was anything to update.  I'm not sure if this is a problem with yum or the system-config-netboot RPM package.  Feel free to reassign.  I'm also puzzled as to why nobody else has reported this, since I would think everyone running nightly updates would see it.  However, it's happened on both FC3 machines here.  I've never actually used system-config-netboot, nor do I do any netbooting to or from these machines.

Version-Release number of selected component (if applicable):
system-config-netboot-0.1.8-1 and later?  or maybe yum...

How reproducible:
Always

Steps to Reproduce:
1.see above
2.
3.
  

Actual Results:  see above

Expected Results:  see above

Additional info:

Yum.conf is the system default, no mods.

--jh--

Comment 1 Jason Vas Dias 2005-07-19 20:08:52 UTC
This problem is caused by the change from using an architecture specific
RPM for system-config-netboot to a noarch RPM (the package contains NO
architecture specific files) - rpm cannot handle upgrades from arch-specific
to no-arch. 
You'll need to upgrade this manually:
 $ wget \  
ftp://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/system-config-netboot-0.1.16-1_FC3.noarch.rpm
 $ rpm -Uvh --force system-config-netboot-0.1.16-1_FC3.noarch.rpm

After this, subsequent upgrades will be installed normally through yum/up2date.

If, as you say: " I've never actually used system-config-netboot, nor do I do
any netbooting to or from these machines ", then you'd be better off simply doing
 $ rpm -e system-config-netboot
which would also fix the problem.


Note You need to log in before you can comment on or make changes to this bug.