Bug 163696 - Locking system should prevent rebooting the system
Locking system should prevent rebooting the system
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn370
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-20 10:00 EDT by Matthew Davis
Modified: 2007-04-18 13:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-20 10:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Davis 2005-07-20 10:00:59 EDT
Description of problem:

When you lock a system, it should not allow you to schedule a reboot for the
system.  Per the doc (6.4.4.8.4. System Set Manager ⇒ Misc ⇒ Lock Systems):

"Selecting the appropriate systems and then clicking the Lock Systems link
prevents the scheduling of any action through RHN that would affect the systems.
This can be reversed by clicking the Unlock Systems link."

Since a reboot is an action, it should stop it from happening.

Steps to reproduce:
1. Lock a system
2. Schedule a reboot

Expected results:
Not allow you to schedule a reboot

Actual results:
Reboot is scheduled

Tested and reproduced on 3.7.1

Note You need to log in before you can comment on or make changes to this bug.