Bug 163753 - SDL causes BadMatch errors in Metacity with 24-bit color
SDL causes BadMatch errors in Metacity with 24-bit color
Status: CLOSED DUPLICATE of bug 163754
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-20 16:21 EDT by Emily Brantley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-20 16:32:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emily Brantley 2005-07-20 16:21:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JPM; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
When running any program that uses SDL (frozen-bubble is a good example but not the only one) and X11 display is set to 24-bit color, metacity terminates immediately with BadMatch errors (over and over, since gnome-session tries to restart it over and over).  Changing to 16-bit color, metacity acts fine.

I can try to paste the BadMatch error, if needed.  Should this bug be filed for the SDL component ?  (SDL-1.2.8-3.2)

Version-Release number of selected component (if applicable):
metacity-2.10.2-1

How reproducible:
Always

Steps to Reproduce:
1. run X in 24-bit
2. log in to gnome
3. install and run frozen-bubble

Actual Results:  metacity "crashes" over and over, eventually giving up.  end up window-managerless.

Expected Results:  metacity should remain.

Additional info:

SDL is version SDL-1.2.8-3.2
Comment 1 Ray Strode [halfline] 2005-07-20 16:32:03 EDT

*** This bug has been marked as a duplicate of 163754 ***

Note You need to log in before you can comment on or make changes to this bug.