Bug 16386 - Strange message after upgrade from 6.2 to qa0816.0
Strange message after upgrade from 6.2 to qa0816.0
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: db1 (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Winston gold
:
: 15511 16411 (view as bug list)
Depends On:
Blocks: 16270
  Show dependency treegraph
 
Reported: 2000-08-16 13:53 EDT by David Lawrence
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-31 10:12:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2000-08-16 13:53:55 EDT
/usr/lib/rpm/rpmq: /usr/i486-linux-libc5/lib/libdb.so.2:  no version
information
                  available (required by /usr/lib/librpm.so.0)
This message appears after upgrading from 6.2 to qa0816.0 when doing a rpm
-qa.
Comment 1 Glen Foster 2000-08-16 16:40:53 EDT
This defect is considered MUST-FIX for Winston Gold release.

Derek says this looks like someone has stripped a library twice...
Comment 2 Bill Nottingham 2000-08-16 17:35:42 EDT
db1 isn't installed.
Comment 3 Bill Nottingham 2000-08-16 23:38:14 EDT
*** Bug 16411 has been marked as a duplicate of this bug. ***
Comment 4 Nalin Dahyabhai 2000-08-17 17:22:58 EDT
Unbundling libdb from glibc removed the versioning, which allows the old libc5
package to "supply" the libdb.so.2 that rpm wants from db2.
Comment 5 Jeff Johnson 2000-08-18 13:28:19 EDT
Pending fix is adding to rpm-4.0-0.69
	Requires: db1 = 1.85
Comment 6 Glen Foster 2000-08-18 15:27:26 EDT
This defect is considered MUST-FIX for Winston Gold release
Comment 7 Bill Nottingham 2000-08-18 17:06:35 EDT
*** Bug 15511 has been marked as a duplicate of this bug. ***
Comment 8 Jeff Johnson 2000-08-18 17:45:08 EDT
Fixed in rpm-4.0-0.69.
Comment 9 Andrea Borgia 2000-08-27 11:30:14 EDT
Upgrading 6.2 to RC2 still forgets to install db1 when libc is present (i.e., almost always)
Comment 10 Brock Organ 2000-08-31 10:12:34 EDT
verified this is resolved in post-RC2 builds and is fixed in the final version
...

Note You need to log in before you can comment on or make changes to this bug.