Bug 16386 - Strange message after upgrade from 6.2 to qa0816.0
Summary: Strange message after upgrade from 6.2 to qa0816.0
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: db1   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard: Winston gold
Keywords:
: 15511 16411 (view as bug list)
Depends On:
Blocks: 16270
TreeView+ depends on / blocked
 
Reported: 2000-08-16 17:53 UTC by David Lawrence
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-31 14:12:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Tattersall 2000-08-16 17:53:55 UTC
/usr/lib/rpm/rpmq: /usr/i486-linux-libc5/lib/libdb.so.2:  no version
information
                  available (required by /usr/lib/librpm.so.0)
This message appears after upgrading from 6.2 to qa0816.0 when doing a rpm
-qa.

Comment 1 Glen Foster 2000-08-16 20:40:53 UTC
This defect is considered MUST-FIX for Winston Gold release.

Derek says this looks like someone has stripped a library twice...

Comment 2 Bill Nottingham 2000-08-16 21:35:42 UTC
db1 isn't installed.

Comment 3 Bill Nottingham 2000-08-17 03:38:14 UTC
*** Bug 16411 has been marked as a duplicate of this bug. ***

Comment 4 Nalin Dahyabhai 2000-08-17 21:22:58 UTC
Unbundling libdb from glibc removed the versioning, which allows the old libc5
package to "supply" the libdb.so.2 that rpm wants from db2.

Comment 5 Jeff Johnson 2000-08-18 17:28:19 UTC
Pending fix is adding to rpm-4.0-0.69
	Requires: db1 = 1.85

Comment 6 Glen Foster 2000-08-18 19:27:26 UTC
This defect is considered MUST-FIX for Winston Gold release

Comment 7 Bill Nottingham 2000-08-18 21:06:35 UTC
*** Bug 15511 has been marked as a duplicate of this bug. ***

Comment 8 Jeff Johnson 2000-08-18 21:45:08 UTC
Fixed in rpm-4.0-0.69.

Comment 9 Andrea Borgia 2000-08-27 15:30:14 UTC
Upgrading 6.2 to RC2 still forgets to install db1 when libc is present (i.e., almost always)

Comment 10 Brock Organ 2000-08-31 14:12:34 UTC
verified this is resolved in post-RC2 builds and is fixed in the final version
...


Note You need to log in before you can comment on or make changes to this bug.