Bug 163898 - glib2 2.7.3-1 breaks REMOTE gdmgreeter (graphical)
glib2 2.7.3-1 breaks REMOTE gdmgreeter (graphical)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-21 16:34 EDT by Michael Lee Yohe
Modified: 2008-02-05 18:38 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 18:38:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2005-07-21 16:34:24 EDT
Description of problem:
I upgraded a local development box from FC4's glib2 2.6.4 to 2.7.3 (rawhide) a
few days ago.  Today, I noticed when I logged out of the machine - I was unable
to log back in remotely via the gdm graphical greeter.  I would enter my user
name and password - it would immediately exit.  I enabled debug on gdm - but no
useful descriptions were made other than it informed that it was going to
terminate.  gdm would not exit if you specified an invalid user or password.

I began reverting packages one by one to FC4's release.  When re-installing
2.6.4, logins worked normally.  Something in glib2-2.7.3-1 breaks the graphical
greeter after a successful password entry.

Version-Release number of selected component (if applicable):
glib2-2.7.3-1

How reproducible:
Everytime

Steps to Reproduce:
1. Enable "graphical greeter" in gdmsetup.
2. Update to rawhide glib2 2.7.3-1.
2. Restart gdm (init 3 then init 5)
3. Attempt to login remotely (X -query localhost :1 if on the same machine).
4. Enter user name properly.
5. Enter password properly.
  
Actual results:
Your session is terminated prematurely.

Expected results:
Normal login should occur.

Additional info:
Pulled from debug gdm messages from /var/log/messages.

Jul 21 14:59:30 localhost gdm[2689]: XDMCP: Start up on host bigputer, port 177
Jul 21 14:59:30 localhost gdm[2689]: gdm_start_first_unborn_local: Starting :0
Jul 21 14:59:30 localhost gdm[2689]: gdm_display_manage: Managing :0
Jul 21 14:59:30 localhost gdm[2689]: loop check: last_start 0, last_loop 0, now:
1121975970, retry_count: 0
Jul 21 14:59:30 localhost gdm[2689]: Resetting counts for loop of death detection
Jul 21 14:59:30 localhost gdm[5784]: gdm_slave_start: Starting slave process for :0
Jul 21 14:59:30 localhost gdm[5784]: gdm_slave_start: Loop Thingie
Jul 21 14:59:30 localhost gdm[5784]: Sending VT_NUM == -1 for slave 5784
Jul 21 14:59:30 localhost gdm[5784]: Sending VT_NUM 5784 -1
Jul 21 14:59:30 localhost gdm[2689]: gdm_display_manage: Forked slave: 5784
Jul 21 14:59:30 localhost gdm[2689]: Accepting XDMCP connections...
Jul 21 14:59:30 localhost gdm[2689]: Handling message: 'VT_NUM 5784 -1'
Jul 21 14:59:30 localhost gdm[2689]: Got VT_NUM == -1
Jul 21 14:59:30 localhost gdm[5784]: gdm_server_start: :0
Jul 21 14:59:30 localhost gdm[5784]: gdm_auth_secure_display: Setting up access
for :0
Jul 21 14:59:30 localhost gdm[5784]: gdm_auth_secure_display: Setting up access
Jul 21 14:59:30 localhost gdm[5784]: gdm_auth_secure_display: Setting up access
for :0 - 1 entries
Jul 21 14:59:30 localhost gdm[5784]: Sending COOKIE == <secret> for slave 5784
Jul 21 14:59:30 localhost gdm[5784]: Sending COOKIE 5784 d2...
Jul 21 14:59:30 localhost gdm[2689]: Handling message: 'COOKIE 5784 d2...'
Jul 21 14:59:30 localhost gdm[2689]: Got COOKIE == <secret>
Jul 21 14:59:30 localhost gdm[5784]: gdm_server_spawn: Forked server on pid 5789
Jul 21 14:59:30 localhost gdm[5784]: do_server_wait: Before mainloop waiting for
server
Jul 21 14:59:31 localhost gdm[5789]: gdm_server_spawn: '/usr/X11R6/bin/X :0
-audit 0 -auth /var/gdm/:0.Xauth vt7'
Jul 21 14:59:31 localhost gdm[5784]: gdm_server_start: After mainloop waiting
for server
Jul 21 14:59:31 localhost gdm[2689]: (child 5784) gdm_server_usr1_handler: Got
SIGUSR1, server running
Jul 21 14:59:31 localhost gdm[5784]: gdm_server_start: Completed :0!
Jul 21 14:59:31 localhost gdm[5784]: Sending VT_NUM == 7 for slave 5784
Jul 21 14:59:31 localhost gdm[5784]: Sending VT_NUM 5784 7
Jul 21 14:59:31 localhost gdm[2689]: Handling message: 'VT_NUM 5784 7'
Jul 21 14:59:31 localhost gdm[2689]: Got VT_NUM == 7
Jul 21 14:59:31 localhost gdm[5784]: Sending XPID == 5789 for slave 5784
Jul 21 14:59:31 localhost gdm[5784]: Sending XPID 5784 5789
Jul 21 14:59:31 localhost gdm[2689]: Handling message: 'XPID 5784 5789'
Jul 21 14:59:31 localhost gdm[2689]: Got XPID == 5789
Jul 21 14:59:31 localhost gdm[5784]: gdm_slave_run: Opening display :0
Jul 21 14:59:31 localhost gpm[2367]: *** info [mice.c(1766)]:
Jul 21 14:59:31 localhost gpm[2367]: imps2: Auto-detected intellimouse PS/2
Jul 21 14:59:33 localhost kernel: agpgart: Found an AGP 2.0 compliant device at
0000:00:00.0.
Jul 21 14:59:33 localhost kernel: agpgart: Putting AGP V2 device at 0000:00:00.0
into 1x mode
Jul 21 14:59:33 localhost kernel: agpgart: Putting AGP V2 device at 0000:01:00.0
into 1x mode
Jul 21 14:59:35 localhost gdm[5784]: Sending START_NEXT_LOCAL
Jul 21 14:59:35 localhost gdm[2689]: Handling message: 'START_NEXT_LOCAL'
Jul 21 14:59:35 localhost gdm[5784]: gdm_slave_greeter: Running greeter on :0
Jul 21 14:59:35 localhost gdm[5784]: gdm_slave_greeter: Greeter on pid 5839
Jul 21 14:59:35 localhost gdm[5784]: Sending GREETPID == 5839 for slave 5784
Jul 21 14:59:35 localhost gdm[5784]: Sending GREETPID 5784 5839
Jul 21 14:59:35 localhost gdm[2689]: Handling message: 'GREETPID 5784 5839'
Jul 21 14:59:35 localhost gdm[2689]: Got GREETPID == 5839
Jul 21 14:59:37 localhost gdm[5784]: gdm_slave_wait_for_login: In loop
Jul 21 14:59:37 localhost crond(pam_unix)[5743]: session closed for user myohe
Jul 21 14:59:37 localhost gdmgreeter[5839]: Unexpected greeter command received:
'  '
Jul 21 14:59:37 localhost gdm[5784]: term_quit: Final cleanup
Jul 21 14:59:37 localhost gdm[5784]: gdm_slave_quick_exit: Will kill everything
from the display
Jul 21 14:59:37 localhost gdm[5784]: Running gdm_verify_cleanup and pamh != NULL
Jul 21 14:59:37 localhost gdm[5784]: gdm_server_stop: Server for :0 going down!
Jul 21 14:59:37 localhost gdm[5784]: gdm_server_stop: Killing server pid 5789
Jul 21 14:59:38 localhost gdm[5784]: gdm_server_stop: Server pid 5789 dead
Jul 21 14:59:38 localhost gdm[5784]: gdm_slave_quick_exit: Killed everything
from the display
Jul 21 14:59:38 localhost gdm[2689]: mainloop_sig_callback: Got signal 17
Jul 21 14:59:38 localhost gdm[2689]: gdm_cleanup_children: child 5784 returned 65
Jul 21 14:59:38 localhost gdm[2689]: gdm_child_action: In remanage
Jul 21 14:59:38 localhost gdm[2689]: gdm_display_manage: Managing :0
Jul 21 14:59:38 localhost gdm[2689]: loop check: last_start 1121975970,
last_loop 1121975970, now: 1121975978, retry_count: 1
Jul 21 14:59:38 localhost gdm[5852]: gdm_slave_start: Starting slave process for :0
Jul 21 14:59:38 localhost gdm[5852]: gdm_slave_start: Loop Thingie
Jul 21 14:59:38 localhost gdm[5852]: gdm_slave_run: Sleeping 1 seconds before
server start

(rinse/repeat)
Comment 2 John Thacker 2006-05-05 16:20:54 EDT
Can you reproduce this in a stable version of glib2, like in 2.10.x
in FC5?  If not, this should be closed.
Comment 4 Matthias Clasen 2008-02-05 18:38:56 EST
Closing this now. Too many releases have passed since this was originally reported.

Note You need to log in before you can comment on or make changes to this bug.