Bug 163903 - pilot-link does not work with usb palm devices
pilot-link does not work with usb palm devices
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Depends On:
  Show dependency treegraph
Reported: 2005-07-21 16:58 EDT by Robert Williams
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-22 09:58:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
palm sync kernel oops (6.91 KB, text/plain)
2007-03-19 13:35 EDT, das_deniz
no flags Details

  None (edit)
Description Robert Williams 2005-07-21 16:58:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.7.8-1.4.1

Description of problem:
Pilot-link utilities such as pilot-xfer do not work well, if at all,
on any of my Fedora 4 and Red Hat Enterprize systems when using USB
palm devices.   This seems to be more of a problem with
my Tungsten E than with my Tungsten T.
This also means that graphical tools such as kpilot
and the Evolution palm module also do not work well if at all.
The problem is related to how the /dev/ttyUSB0,1,2,3... are created only
after some considerable delay when the sync icon is tapped on the palm
device.  If symlinks are created in dev from these devices to /dev/pilot,
there isn't much improvement.   


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Connect USB palm device to system.
2. Tap hotsync icon on palm.
3. Execute "pilot-xfer -p [/dev/ttyUSB0 || /dev/ttyUSB1 ] -i myfile.prc

Actual Results:  The palm may or may not sync with the usb port.

Expected Results:  Connection and install should proceed.

Additional info:

Again, see
Comment 1 Jan "Yenya" Kasprzak 2005-12-19 14:07:00 EST
I see the similar behaviour with Tungsten T5. It is probably some weird
udev/kernel thing - the /dev/ttyUSB* devices are created several seconds after
the hot-sync button is pressed (altough the message about new ttyUSB devices in
the kernel log appears instantly), and pilot-link (or jpilot) apparently has a
rather small window to catch up with the Palm device then.

I have even tried a bleeding edge system - the 2.6.15-rc6 kernel compiled by
myslef, and rawhide RPMs recompiled for FC4 (just rpmbuild --rebuild src.rpm) of
udev-077, jpilot-0.99.8-2.1, pilot-link-0.12.0-0.pre4.5.1 - the problem is still
here. I run x86_64, so I am for changing the "hardware" field from "i386" to "all".

I am sure this has already been reported there, but I cannot find it right now.
Comment 2 Ivana Varekova 2006-11-30 08:38:36 EST
Could you please try to reproduce your bug this the latest version of pilot-link
Comment 3 das_deniz 2007-03-19 13:35:05 EDT
Created attachment 150397 [details]
palm sync kernel oops

with f7 (devel) and pilot-link-0.12.1-5.fc7 and my trep 700p connected via USB
i can see in the syslog the msgs about the device being attached to ttyUSB0 and

launch gpilotd-control-applet specify 'USB' connnection on device /dev/ttyUSB0
-- choose "yes i've used sync software with this PDA before" and click forward
to 'retrieve Owner Name and ID from the PDA'

as soon as i press the sync button for the device we get a kernel oops.
Comment 4 Serguei Miridonov 2007-07-23 11:47:13 EDT
It appears the expeirence of many people with PalmOS devices shows that pilot-
link-0.12.1 compiled with libusb support works much better (faster and more 
stable) than Fedora's stock pilot-link using visor driver. I'm sure libusb 
support must be default in Fedora. See https://bugzilla.redhat.com/bugzilla/

However, some USB stuff seems to be broken in new kernel (see 

May I ask a question? This bug report was filed two years ago and the progress 
seems really too slow. Why is that? My question to Ivana Varekova: what is the 
problem? Are there compatibility problems with other devices? Do you need some 

P.S. It seems das_deniz had not marked his report as providing requested 
information, so I do it right now in order to change the status of this bug.
Comment 5 Ivana Varekova 2007-08-22 09:58:00 EDT
Hello, now in fc7/devel branch there are versions with usb support
(pilot-link-0.12.2-4.fc8/pilot-link-0.12.2-4.fc7). There remains problem with
permissions (#158809). 

The answer for Serguei Miridonov - I'm sorry, I didn't have enough time to solve
this problem. The situation has changed, though, so it should be better now.

Note You need to log in before you can comment on or make changes to this bug.