Bug 163922 - LIBGCJ_LICENSE missing
LIBGCJ_LICENSE missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-21 20:02 EDT by Robin Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.0.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 03:43:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-07-21 20:02:01 EDT
The file /usr/share/doc/libgcj-devel-4.0.1/README.libjava says "libgcj is free
software.  See the file LIBGCJ_LICENSE for copying permission." However, the
file LIBGCJ_LICENSE is not installed anywhere (afaics).

This is important because the libgcj license is slightly unusual
(GPL-with-exception). People might wrongly assume that it is LGPL, or GPL.
Comment 1 Rahul Sundaram 2005-09-04 22:39:20 EDT
It is important that packages include the license regardless of whether its
unusual or not. We already mandate this by policy for Fedora Extras.

https://www.redhat.com/archives/fedora-maintainers/2005-September/msg00002.html
Comment 2 Tom Tromey 2005-09-09 13:15:49 EDT
Reassigning to Jakub as this seems to be a gcc packaging issue.

Note You need to log in before you can comment on or make changes to this bug.