Bug 163947 - gphoto2 fails while downloading avi files
gphoto2 fails while downloading avi files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-22 05:57 EDT by Mikko V
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.1.99
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-22 16:01:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logfile of gphoto2 --debug --get-all-files (4.95 MB, text/plain)
2005-07-22 06:00 EDT, Mikko V
no flags Details

  None (edit)
Description Mikko V 2005-07-22 05:57:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
gphoto2 is unable to download avi files from my camera (Canon Powershot S1 IS). A logfile of env LANG=C gphoto2 --debug --get-all-files is included as an attachment.

Note: this camera worked perfectly with avi files on FC3. The problem has occurred after upgrade to FC4.

Note: I have tried this with different videos and three different memory cards. Problem still exists.

Most important lines from log:

4.119278 gphoto2-port(2): Reading 18206206=0x115cdfe bytes from port...
gp_port_read: Resource temporarily unavailable
12.119957 PTP2/library.c(2): PTP: gp_port_* function returned 0xffffffde         -34
12.119998 context(0): PTP I/O error

*** Error ***
PTP I/O error
12.120040 libgphoto2/gphoto2-filesys.c(2): Download of 'MVI_2981.AVI' from '/store_00010001/DCIM/129CANON' (type 1) failed. Reason: 'Unspecified error'
12.120057 gphoto2-camera(2): Operation failed!
*** Error (-1: 'Unspecified error') ***

12.120401 gp-camera(2): Freeing camera...


Version-Release number of selected component (if applicable):
gphoto2-2.1.5-10

How reproducible:
Always

Steps to Reproduce:
1. See description of bug
2.
3.
  

Actual Results:  See description

Expected Results:  It should have downloaded the avi files.

Additional info:
Comment 1 Mikko V 2005-07-22 06:00:55 EDT
Created attachment 117049 [details]
Logfile of gphoto2 --debug --get-all-files
Comment 2 Tim Waugh 2005-08-02 08:37:08 EDT
Does this test update fix the problem?:

https://www.redhat.com/archives/fedora-test-list/2005-July/msg00376.html
Comment 3 Mikko V 2005-08-03 17:52:58 EDT
(sorry for the delay, for some reason I didn't get an email when you added your
comment)

Anyway, I don't know if the test update fixes this particular problem, because
with the test version I'm even unable to list (--list-files) the files nor
download them (--get-all-files):

Detected a 'Canon:PowerShot S1 IS (normal mode)'.

*** Error ***
lock keys failed.
*** Error (-114: 'OS error in camera communication') ***
Comment 4 Radek Vokal 2006-01-08 11:11:13 EST
Can you please retest your issue with the latest gphoto2-2.1.99 package from
rawhide? Thanks
Comment 5 Mikko V 2006-01-20 17:20:39 EST
I've recently switched to ubuntu and don't have any fedora core machines
anymore. So sorry, no can do :(

Note You need to log in before you can comment on or make changes to this bug.