This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 163972 - MySQL server fails on startup
MySQL server fails on startup
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
3
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-22 11:31 EDT by Josep Ferrer Tura
Modified: 2013-07-02 23:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-30 09:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josep Ferrer Tura 2005-07-22 11:31:28 EDT
Description of problem:
=======================
MySQL fails on startup, in mysql.log i've got...

050721 21:03:20  mysqld started
050721 21:03:20 [Warning] Asked for 196608 thread stack, but got 126976
InnoDB: Error: pthread_create returned 11
050721 21:03:20  mysqld ended

-MySQL 4.1.13
-Linux Fedora Core 3 is recently automatically actualized with up2date Kernel 2.6.12

Steps to Reproduce:
===================
-Install Fedora Core 3 (DVD) (full) kernel 2.6.9
-Uninstall mysql 3.2xxxx
-Download and install MySQL-x-4.1.13-i386.rpm server, client, and shared libraries :
   --MySQL-server 4.1.13  
   --MySQL-client 4.1.13  
   --MySQL-shared 4.1.13
-Start MySQL    OK !!
-Update FC3 ..kernel 2.6.12
-Reboot system
-Restart MySQL  FAIL !!!
  
Questions (& answers) to MySQL experts :
========================================
[21 Jul 22:36] Josep Ferrer Tura

Description:
MySQL fails on startup, in mysql.log i've got...

050721 21:03:20  mysqld started
050721 21:03:20 [Warning] Asked for 196608 thread stack, but got 126976
InnoDB: Error: pthread_create returned 11
050721 21:03:20  mysqld ended

Linux Fedora Core 3 is recently automatically actualized - Kernel 2.6.12
MySQL 4.1.13

How can I resolve it ?

Thanks. 

How to repeat:
-Install Fedora Core 3 (DVD)  (full) kernel 2.6.9
-Uninstall mysql 3.2xxxx
-Download and install i386 RPM:
   --MySQL-server  4.1.x  
   --MySQL-client   4.1.x  
   --MySQL-shared 4.1.x  
-Start MySQL    OK !!
-Update Linux  ....kernel 2.6.12
-Reboot system
-Restart MySQL  FAIL !!!
============================================================================
[22 Jul 2:14] Heikki Tuuri

Hi!

Actually, this is a duplicate of an earlier bug report. Also one other user
reported FC 3 returning 11, about a month ago.

Please check that you have not exhausted your computer's memory.

My guess is that this is a bug in FC 3. You should report this to the vendor of
FC 3.

Regards,

Heikki
==============================================================================
[22 Jul 13:28] Aleksey Kishkin

duplicate of http://bugs.mysql.com/bug.php?id=11875

Related messages from MySQL:
============================
[12 Jul 7:20] Frederico Madeira

Description:
After update kernel from version 2.6.9-1.667 to version 2.6.11-1.35_FC3 the
mysql-server 4.1.12-1.i386 don't start.

After i reboot the machine, and load the new kernel, the mysql don't start.
Logged the follow error in /var/log/mysql.log:

050711 00:41:14 mysqld started
050711 0:41:14 [Warning] Asked for 196608 thread stack, but got 126976
InnoDB: Error: pthread_create returned 11
050711 00:41:15 mysqld ended

When i reboot and load the old kernel, mysql start normaly.

How to repeat:
Installed the FC3 with the default mysql version:
mysql-server-3.23.58-13.i386.rpm 
Run up2date and update all packages  including kernel from version 2.6.9-1.667
to version 2.6.11-1.35_FC3.
After, update the mysql to version MySQL-server-4.1.12-1.i386.rpm. 

After, reboot the machine, and load the new kernel. The mysql don't start.

After, reboot and load the old kernel, mysql start normaly.
==============================================================================
Suggested fix:
unknow
==============================================================================
[12 Jul 8:28] Heikki Tuuri

Hi!

man pthread_create says:

ERRORS
       EAGAIN not enough system resources to create a process for
              the new thread.

       EAGAIN more than PTHREAD_THREADS_MAX threads  are  already
              active.

Have you exhausted the computer's memory?

Are you sure that you did the upgrade to Fedore Core 3 in the right way? Maybe
an inconsistency of the kernel and the glibc?

Regards,

Heikki
==============================================================================
[12 Jul 13:58] Frederico Madeira

I have 512Mb RAM and i use the up2date to update all packages. 
When i boot with new kernel, all services start normaly instead mysql. If i
ignore them on startup, my system work fine with all oyther applications.
Only mysql is affected.
==============================================================================
[12 Jul 15:03] Heikki Tuuri

Maybe your other applications do not call pthread_create()? I am putting this
bug report to the 'Can't repeat' state, since I do not recall anyone else
reporting this from a recent Linux distro. This may be a bug in your particular
Linux distribution, or a configuration or installation error. You should
double-check that mysqld cannot exhaust your computer's memory.

Regards,

Heikki
==============================================================================
[12 Jul 17:22] Frederico Madeira

How i can debug this problem on my system ??
Have any tool available ??
==============================================================================
[13 Jul 16:28] Marko Mäkelä
Try strace or gdb.
Comment 1 Emek TUZUN 2005-08-26 17:26:38 EDT
For a quick, temp solution:
Try to set mysqld_disable_trans=1 in booleans file in /etc/selinux/targeted
Have a reboot, then MySQL should start normally...

Good luck,

Emek TUZUN
Comment 2 Tom Lane 2005-09-30 14:25:35 EDT
Did the suggested selinux tweak solve the problem?  I can't reproduce the
problem on 2.6.13 (current FC4 kernel).
Comment 3 John Thacker 2006-04-30 09:48:19 EDT
No response from reporter to request for info.
Also, FC3 is the responsibility of Fedora Legacy.
If the reporter can offer the needed information and this still
occurs in FC4 or FC5, please reopen.


Note You need to log in before you can comment on or make changes to this bug.