Bug 163999 - Broken Multi-Map Behavior
Broken Multi-Map Behavior
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-22 14:58 EDT by Chris Feist
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 03:36:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Feist 2005-07-22 14:58:01 EDT
+++ This bug was initially created as a clone of Bug #139633 +++

Description of problem:

Using executable maps to imitate the Sun "-hosts" map functionality 
doesn't work because the exported filesystem paths cannot 
contain spaces


Version-Release number of selected component (if applicable):

4.1.3-12

*** Information for Problem #1 - Spaces in Exported Paths ***

Steps to Reproduce:
1. Make sure that the /net mountpoint is defined in /etc/auto.master 
and that it is running with the standard executable map /etc/auto.net
2. Run: mkdir -p '/tmp/testing/this is a test'
3. Run: exportfs '*:/tmp/testing/this is a test'
4. Run: ls /net/localhost/tmp

Actual results:
All you see under /net/localhost/tmp/testing is 'this'.

Expected results:
You should have seen 'this is a test', which is what Sun's 
automounter does.
Comment 1 Jeffrey Moyer 2006-04-19 17:05:19 EDT
Ian, this may be related to 60239.
Comment 2 Ian Kent 2006-04-19 21:57:06 EDT
(In reply to comment #1)
> Ian, this may be related to 60239.

I'll investigate.
Comment 3 Ian Kent 2006-06-21 21:39:48 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > Ian, this may be related to 60239.
> 
> I'll investigate.
> 

Chris, sorry to take so long to get back but I missed this
but believe I've fixed this now.

Could you please verify this with the latest FC-4 or FC-5
update.
Comment 4 Ian Kent 2006-12-19 03:36:38 EST
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > Ian, this may be related to 60239.
> > 
> > I'll investigate.
> > 
> 
> Chris, sorry to take so long to get back but I missed this
> but believe I've fixed this now.
> 
> Could you please verify this with the latest FC-4 or FC-5
> update.

Last chance.
If I don't hear back by Friday 22nd I will close this as
fixed CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.