Bug 164006 - evolution hangs when "new mail notification" enabled
evolution hangs when "new mail notification" enabled
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Depends On:
  Show dependency treegraph
Reported: 2005-07-22 16:38 EDT by Need Real Name
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-15 09:40:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
gdb (4.36 KB, text/plain)
2005-07-22 16:39 EDT, Need Real Name
no flags Details
gdb (2.92 KB, text/plain)
2005-07-22 17:03 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2005-07-22 16:38:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Epiphany/1.6.3

Description of problem:
Evolution is hanging when sending/receiving email.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Additional info:

# rpm -qa evolution

There is no debuginfo package for evolution, so the stack trace won't be great.

pop3 mailbox.
Comment 1 Need Real Name 2005-07-22 16:39:13 EDT
Created attachment 117078 [details]
Comment 2 Dave Malcolm 2005-07-22 16:49:21 EDT
Thanks.  Unfortunately that stack trace isn't usable.

Please can you do a "t a a bt" in gdb.
Comment 3 Need Real Name 2005-07-22 17:03:39 EDT
Created attachment 117081 [details]

I was attaching gdb to an already running program. Not sure where to type that.

Anyway, since it's hanging every single time now..
Comment 4 Need Real Name 2005-07-22 17:16:36 EDT
I have a feeling this is due to a corrupt index.
If I drag bugmail to a separate folder, evolution hangs.

I see this on the command line:
(evolution:12688): camel-WARNING **: Invalid root:

I can't say whether this is normal. The file exists.
Comment 5 Need Real Name 2005-07-22 17:27:06 EDT
It wasn't an index problem. I renamed the ibex.index files, and I still get both
the error and the problem.

CAMEL_DEBUG=all doesn't help either.
The problem (currently) only occurs when I move mails from my Inbox to the other
folder, i.e. not on send/receive.
Comment 6 Need Real Name 2005-07-22 17:44:34 EDT
I found the culprit. I have a sound play when new mail arrives.
Because of bug 163462, this effects a mail move too.

Disabling the sound works. The sound file exists, and has not been changed.
Comment 7 Dave Malcolm 2005-07-22 18:18:35 EDT
From the 2nd backtrace, it looks like it's trying to start the soud daemon and
waiting forever for a response.

Do other apps using sound work OK?
Comment 8 Need Real Name 2005-07-22 18:31:42 EDT
I don't have any proper Gnome apps that I use sound with. realplay works.

As a test, I ran the game Robots and made sure sound was enabled.
I have no idea how to play the game, but clicking the mouse a few times made it
hang, so I suppose I do have a problem with sound.
Comment 10 Matthew Barnes 2007-10-05 11:49:02 EDT
Is this problem still present on Fedora 8 Test 2 or later?
Comment 11 Need Real Name 2007-10-12 14:23:22 EDT
Unfortunately I don't have a spare box to put F8T2 on.
Comment 12 Matthew Barnes 2007-10-16 15:02:40 EDT
Setting this back to NEEDINFO to help me track it.  Given it's age, I'll likely
close it in a few months unless someone claims the problem still exists on F8.
Comment 13 Matěj Cepl 2007-12-10 16:48:28 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Evolution.
If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 14 Matěj Cepl 2008-01-15 09:40:20 EST
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional


{This is mass-closing of all obsolete bugs; if this bug was in your opinion
closed by mistake, please, reopen it with additional information; thanks a lot
and I am sorry for bothering you in such case.}

Note You need to log in before you can comment on or make changes to this bug.