Bug 164007 - sound problem with ESS Technology ES1988 Allegro-1 on HP N5430
sound problem with ESS Technology ES1988 Allegro-1 on HP N5430
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-22 16:38 EDT by Stephen E Clark
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-16 10:10:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv output (7.62 KB, text/plain)
2005-07-22 16:38 EDT, Stephen E Clark
no flags Details

  None (edit)
Description Stephen E Clark 2005-07-22 16:38:19 EDT
Description of problem:
Sound does not work with KDE and get stuck with GNOME, on HP Pavilion N5430 Laptop.

Version-Release number of selected component (if applicable):
2.6.12-1.1398_FC4 #1 Fri Jul 15 00:52:32 EDT 2005 i686 athlon i386 GNU/Linux

How reproducible:
evry time on my hardware - Redhat 9 did not exhibit this problem.

Steps to Reproduce:
1.from command line enter oqg123 -d oss somesoundfile.ogg
2.
3.
  
Actual results:
sound repeats or gets stuck and have to kill ogg123 if stuck. Had to kill esd
when using GNOME.

Expected results:
Sound to play correctly.

Additional info:
Sound worked with Redhat 9.
Comment 1 Stephen E Clark 2005-07-22 16:38:20 EDT
Created attachment 117077 [details]
lspci -vvv output
Comment 2 John (J5) Palmieri 2005-07-22 16:45:50 EDT
have you tried alsa as your output?  We don't support oss anymore.
Comment 3 Stephen E Clark 2005-07-23 11:38:25 EDT
I reloaded FC4 and at least the alsa sound system is detected now. It still
gives me errors and repeats over and over. See information below:
root@joker4 ~]# ogg123 /home/sclark/JSBACH_S996_01.ogg

Audio Device:   Advanced Linux Sound Architecture (ALSA) output

Playing: /home/sclark/JSBACH_S996_01.ogg
Ogg Vorbis stream: 2 channel, 44100 Hz
ALSA write error: Input/output error2  (127.2 kbps)  Output Buffer  56.2%
ALSA write error: Input/output error2  (123.9 kbps)  Output Buffer  62.5%
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error2  (124.4 kbps)  Output Buffer  84.4%
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error2  (127.9 kbps)  Output Buffer  87.5%
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error2  (123.5 kbps)  Output Buffer  90.6%
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error
ALSA write error: Input/output error2  (135.9 kbps)  Output Buffer  90.6%
ALSA write error: Input/output error
Terminated

I killed from another console - could not ^c.
I was hearing no sound.
Some files would play but repeat 15-20 times and end, other files would play
and repeat and not end - I would have to kill from another window.

root@joker4 ~]# ogg123 /usr/share/sounds/KDE_Window_Sticky.ogg

Audio Device:   Advanced Linux Sound Architecture (ALSA) output

Playing: /usr/share/sounds/KDE_Window_Sticky.ogg
Ogg Vorbis stream: 2 channel, 44100 Hz

Done.
[root@joker4 ~]# ogg123 /usr/share/sounds/KDE_Pop.ogg

Audio Device:   Advanced Linux Sound Architecture (ALSA) output

Playing: /usr/share/sounds/KDE_Pop.ogg
Ogg Vorbis stream: 1 channel, 44100 Hz

Done.
[root@joker4 ~]# ogg123 /usr/share/apps/kfiresaver/kfs_explode.ogg

Audio Device:   Advanced Linux Sound Architecture (ALSA) output

Playing: /usr/share/apps/kfiresaver/kfs_explode.ogg
Ogg Vorbis stream: 2 channel, 44100 Hz

Done.
[root@joker4 ~]# ogg123 /usr/share/sounds/KDE_Water_Drop.ogg

Audio Device:   Advanced Linux Sound Architecture (ALSA) output

Playing: /usr/share/sounds/KDE_Water_Drop.ogg
Ogg Vorbis stream: 1 channel, 44100 Hz
ALSA write error: Input/output error0  ( 64.0 kbps)  Output Buffer  15.5% (EOS)
Terminated
[root@joker4 ~]#
[root@joker4 ~]#
[root@joker4 ~]#
[root@joker4 ~]# ogg123 -v /usr/share/sounds/KDE_Water_Drop.ogg

Audio Device:   Advanced Linux Sound Architecture (ALSA) output
Author:   Bill Currie <bill@taniwha.org>/Kevin Cody, Jr. <kevinc@wuff.dhs.org>
Comments: Outputs to the Advanced Linux Sound Architecture version 0.9.x.

Playing: /usr/share/sounds/KDE_Water_Drop.ogg
Ogg Vorbis stream: 1 channel, 44100 Hz
Vorbis format: Version 0
Bitrate hints: upper=-1 nominal=64000 lower=-1 window=0
Encoded by: Xiph.Org libVorbis I 20030909
ALSA write error: Input/output error0  ( 64.0 kbps)  Output Buffer  15.5% (EOS)
Terminated
[root@joker4 ~]# ogg123 /usr/share/sounds/KDE_Pop.ogg

Audio Device:   Advanced Linux Sound Architecture (ALSA) output

Playing: /usr/share/sounds/KDE_Pop.ogg
Ogg Vorbis stream: 1 channel, 44100 Hz

Done.

Comment 4 Stephen E Clark 2005-07-26 19:40:59 EDT
Additional INFO:
There are no interrupts being generated by the allegro device. I checked in
/proc/interrupts.

As a test of the hardware I booted up a version of Knoppix with kernel 2.4.27 and  
I had sound and there were interrupts being generated by the allegro device. It
is on int 5 by itself in both kernels.
Comment 5 John (J5) Palmieri 2005-07-27 13:27:44 EDT
Any other programs play back the oggs correctly in FC4?  If not then I am
guessing this is a driver bug and should be reassigned to ALSA.
Comment 6 Stephen E Clark 2005-07-27 13:45:32 EDT
I can't get any sound to play right using any method. I have filed a bug report
at alsa-org.
Comment 7 John (J5) Palmieri 2005-07-27 14:22:37 EDT
reassinging this to alsa as the Red Hat maintainers might also know what is
going on with our perticualr version.

To the alsa maintainer -

This has been filed upstream so feel free to close it if you think it is best
handled there.
Comment 8 Stephen E Clark 2005-07-29 23:16:29 EDT
Henry Yuan on the alsa-devel list said he had the same problem and booting with
lapic fixed. This works for me also my HP N5430 laptop just wanted to pass on a
work around.
Comment 9 Martin Stransky 2005-08-16 10:10:40 EDT
If the lapic kernel parameter fixes this issue, it's definitenly a problem with
drivers and a job for upstream...

Note You need to log in before you can comment on or make changes to this bug.