Bug 164047 - duplicate parameter name
Summary: duplicate parameter name
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdemultimedia   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-23 10:56 UTC by David Binderman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 15:35:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Binderman 2005-07-23 10:56:29 UTC
Description of problem:
Hello there,

I just tried to compile Redhat Fedora package
kdemultimedia-3.4.1-1 with the Intel C compiler version 8.1

The compiler said

volumefilter.h(31): error: duplicate parameter name
      bool doFrame(AudioFrame* frame, AudioFrame* frame = 0);
                                                  ^

Clearly broken code.  Suggest rename one of the parameters.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ngo Than 2006-02-22 15:35:10 UTC
It seems to be fixed in new KDE 3.5.1, i don't see this code anymore.
Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.