This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 16405 - RPM of postfix does not install correctly
RPM of postfix does not install correctly
Status: CLOSED DUPLICATE of bug 16404
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-16 18:22 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 18:22:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-16 18:22:01 EDT
Apologies for filing this under "sendmail" but Bugzilla for pinstripe does
not have a "postfix" component.  Postfix is an MTA on the Powertools CD.

The chrooted directories are not included in the postfix RPM off of the
pinstripe Powertools CD.  From the RPM install:

<snip>
[pjl@maynard RPMS]$ sudo rpm -Uvh postfix-20000531-5.i386.rpm
postfix                     ##################################################
install: installing multiple files, but last argument
(/var/spool/postfix/etc) is not a directory
Try `install --help' for more information.
ln: create symbolic link `/var/spool/postfix/usr/lib/zoneinfo' to
`/etc/localtime': No such file or directory
<snip>

A listing of the RPM reveals that the following directories are not included:

/var/spool/postfix/etc
/var/spool/postfix/lib
/var/spool/postfix/maildrop
/var/spool/postfix/usr/lib/zoneinfo

Add the following to %files in the spec file:

%dir %attr(-, root, root) %verify(not md5 size mtime) %{queue_directory}/etc
%dir %attr(-, root, root) %verify(not md5 size mtime) %{queue_directory}/lib
%dir %attr(-, root, root) %verify(not md5 size mtime)
%{queue_directory}/usr/lib/zoneinfo

and all will be happy...
Comment 1 Need Real Name 2000-08-16 18:22:58 EDT

*** This bug has been marked as a duplicate of 16404 ***

Note You need to log in before you can comment on or make changes to this bug.