Bug 164053 - upgrade from FC2 to FC4 leaves dangling rawdevices symlinks
upgrade from FC2 to FC4 leaves dangling rawdevices symlinks
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 164054 164055 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-23 09:24 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 18:26:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-07-23 09:24:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.6 (KHTML, like Gecko) Safari/412.2

Description of problem:


Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade install Fedora Core 4 onto a machine which has Fedora Core 2 installed.
2. check the /etc/rc*.d directories for dangling symlinks.

Actual Results:  lrwxrwxrwx  1 root root 20 Sep 26  2004 rc0.d/K44rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc1.d/K44rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc2.d/K44rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc3.d/S56rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc4.d/S56rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc5.d/S56rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc6.d/K44rawdevices -> ../init.d/rawdevices

all point to /etc/init.d/rawdevices which no longer exists.

Expected Results:  The upgrade of the initscripts rpm during the FC2->FC4 upgrade install should have removed
all symlinks in /etc/rc*.d to *rawdevices.

Additional info:
Comment 1 Bill Nottingham 2005-07-24 22:11:51 EDT
*** Bug 164054 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2005-07-24 22:12:01 EDT
*** Bug 164055 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2005-07-24 22:13:34 EDT
Odd. There's a trigger to take care of this:

%triggerun -- initscripts < 7.62
/sbin/chkconfig --del rawdevices
exit 0

Not sure why it's not being run, or not working.
Comment 4 Need Real Name 2005-07-25 08:57:01 EDT
The trigger is being run since the /etc/init.d/rawdevices script has been deleted 
after the FC2->FC4 upgrade. The question is really why the trigger doesn't
delete the associated symlinks at the same time.
               
Comment 5 Bill Nottingham 2005-07-25 10:02:53 EDT
The trigger doesn't remove the /etc/init.d/rawdevices script - that's done just
by removing the old package. The trigger is just supposed to remove the symlinks.
Comment 6 Need Real Name 2005-07-25 11:02:17 EDT
I should be upgrading another FC2 system to FC4 soon. Is there anything I can
do to try to collect information on the triggerun that should happen when I do
the next upgrade?
Comment 7 Bill Nottingham 2005-07-25 11:06:22 EDT
Paul, Jeremy - is there a sane way to debug what triggers are firing when during
an anaconda upgrade?
Comment 8 Bill Nottingham 2005-09-30 16:25:27 EDT
I've reproduced this.

initscripts.spec has:

%triggerun -- initscripts <= 7.59
/sbin/chkconfig --del random
exit 0

%triggerun -- initscripts < 7.62
/sbin/chkconfig --del rawdevices
exit 0

On upgrade from 7.53, or similar, only the first trigger is being run.

I'll assign this to RPM, and collapse the triggers as of initscripts-8.17-1.

Comment 9 Jeff Johnson 2005-10-05 18:26:59 EDT
rpm has only ever promised to run the 1st trigger *by design*.

Note You need to log in before you can comment on or make changes to this bug.