Bug 164055 - upgrade from FC2 to FC4 leaves dangling rawdevices symlinks
upgrade from FC2 to FC4 leaves dangling rawdevices symlinks
Status: CLOSED DUPLICATE of bug 164053
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-23 09:51 EDT by Need Real Name
Modified: 2014-03-16 22:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-24 22:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-07-23 09:51:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.6 (KHTML, like Gecko) Safari/412.2

Description of problem:


Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade install Fedora Core 4 onto a machine which has Fedora Core 2 installed.
2. check the /etc/rc*.d directories for dangling symlinks.

Actual Results:  lrwxrwxrwx  1 root root 20 Sep 26  2004 rc0.d/K44rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc1.d/K44rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc2.d/K44rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc3.d/S56rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc4.d/S56rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc5.d/S56rawdevices -> ../init.d/rawdevices
lrwxrwxrwx  1 root root 20 Sep 26  2004 rc6.d/K44rawdevices -> ../init.d/rawdevices

all point to /etc/init.d/rawdevices which no longer exists.

Expected Results:  The upgrade of the initscripts rpm during the FC2->FC4 upgrade install should have removed
all symlinks in /etc/rc*.d to *rawdevices.

Additional info:
Comment 1 Bill Nottingham 2005-07-24 22:11:48 EDT

*** This bug has been marked as a duplicate of 164053 ***

Note You need to log in before you can comment on or make changes to this bug.