Bug 16406 - cs46xx on Voyetra turns off amp while CD plays
cs46xx on Voyetra turns off amp while CD plays
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-16 19:09 EDT by Bill Nottingham
Modified: 2014-03-16 22:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-24 08:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2000-08-16 19:09:09 EDT
In the cs46xx driver, it turns off power to the amp even though
a CD is playing. This causes the CD audio to drop out after
a few seconds.

Ideally, you should be able to have it somehow just leave
the amp on, either by default, or with a module parameter.
(or make the power-saving turning off of the amp a module
parameter.)
Comment 1 Alan Cox 2000-08-17 12:18:29 EDT
Ok I think the right answer is to turn the amp on whenever the CD input is
selected. I will investigate if this is doable.
Comment 2 Dan Taylor 2000-08-21 17:40:04 EDT
Still failing in RC2.
Comment 3 Alan Cox 2000-08-22 13:06:18 EDT
I have a possible fix in my build tree. This will go to Bill once I've tested
stuff 
Comment 4 Alan Cox 2000-09-03 07:51:49 EDT
There is a test patch for the power on/off issue in 2.2.18pre2 - its not perfect
it checks MUTE
when it needs to check MUTE | vol ==0 for off. That is next on the list to try


Alan
Comment 5 Alan Cox 2000-09-14 19:53:45 EDT
Bill implemented the volume 0 or muted solution and it seems to work sanely
Comment 6 Michael K. Johnson 2001-12-06 12:29:21 EST
This looks like an accidentally not closed bug report, closing now.

Note You need to log in before you can comment on or make changes to this bug.