Bug 164063 - rpm still uses deprecated "-mcpu="
rpm still uses deprecated "-mcpu="
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-23 15:55 EDT by Gene Czarcinski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-25 14:19:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2005-07-23 15:55:24 EDT
Description of problem:

Fedora Core 4 has gcc-4 and gcc-4 has deprecated the "-mcpu=" parameter (you are
told to use "-mtune=" or "-march="

If rpmbuild is used with the default "i386" architecture then opflags specifies
    "-O2 -g -march=i386 -mcpu=i686"

I have at least one set of packages (nessus) which results in lots of errors if
"-mcpu=i686" is specified for the rpm build.  My current solution is to build
with --target i686

However, this should be fixed and "-mcpu=i686" whould be replaced with "-mtune=i686"
Comment 1 Paul Nasrat 2005-07-25 11:31:08 EDT
Do you have redhat-rpm-config installed?

Please install that for the Fedora specific optflags and confirm that using
march and mtune correctly.

Comment 2 Gene Czarcinski 2005-07-25 14:19:52 EDT
I ma closing this as not-a-bug.

Yes, I did have redhat-rpm-config installed BUT I am also using Mike Harris's
~/.rpmrc and ~/.rpmmacros so I can build packages as non-root and it appears
that the problem is with these two files (where exactly, I don't know yet).

With the files, I get -mcpu=i686 whereas without them I get -mtune=pentium4

Note You need to log in before you can comment on or make changes to this bug.