Bug 164073 - strange dependencies in glibc packages.
strange dependencies in glibc packages.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-07-23 22:18 EDT by Eugene Kanter
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2005-678
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 12:41:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2005-07-23 22:18:43 EDT
Description of problem:

glibc-devel does not depend on the same version glibc. Update glibc-headers does
not force glibc-update - seems very odd.

Version-Release number of selected component (if applicable):

glibc-2.3.4-2 and glibc-2.3.4-2.9

How reproducible:

always

Steps to Reproduce:

rpm -q --requires glibc-headers
  
Actual results:
....
glibc = 2.3.4
....


Expected results:
....
glibc = 2.3.4-2
....


Additional info:
This seems to be correct:
rpm -q --requires glibc
glibc-common = 2.3.4-2
....
Comment 6 Red Hat Bugzilla 2005-10-05 12:41:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-678.html

Note You need to log in before you can comment on or make changes to this bug.