Bug 164095 - can't use update manager
can't use update manager
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-24 17:15 EDT by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 14:38:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Tromey 2005-07-24 17:15:25 EDT
I tried using the update manager to install GEF and draw2d from
eclipse.org's update site.  However, this does not work.
On the Updates wizard page, if I click "Select Required", this will
enable the "Error Details" button; clicking this shows:

Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.pde.source_3.1.0".
/usr/share/eclipse/features/org.eclipse.pde.source_3.1.0/feature.xml (No such
file or directory)

I'm using eclipse-platform-3.1.0_fc-6 from rawhide.
Comment 1 Andrew Overholt 2005-07-25 13:38:28 EDT
Did you have eclipse-tests installed when you tried this?  I think that might be
the problem because I could duplicate when I had it installed but not when I
removed it.

Hmm.  I successfully installed GEF but now when I try to run the update manager
again I get errors on rcp/feature.xml ... I'm wondering if there's something
we're doing with our -devel packages that is messing this up.

Well, after installing all of our packages (including -devel), it doesn't throw
errors.
Comment 2 Tom Tromey 2005-07-26 11:01:03 EDT
I don't have eclipse-tests installed.
Or eclipse-devel for that matter.
Comment 3 Andrew Overholt 2005-07-26 11:13:23 EDT
There isn't an eclipse-devel package.  We have the "main" packages:

eclipse-platform
eclipse-jdt (which needs eclipse-ecj which is split out and can stand alone)
eclipse-pde

and -devel packages for each of these which contain the source for development
within Eclipse:

eclipse-platform-devel
eclipse-jdt-devel
eclipse-pde-devel
Comment 4 Andrew Overholt 2005-10-27 16:31:28 EDT
Can you please try this again with either the latest FC4 test update package or
a rawhide version?
Comment 5 Andrew Overholt 2005-11-01 14:38:20 EST
I actually just successfully installed GEF (and dependencies, I guess) from the
eclipse.org update site using ithe update manager.  This was done with the 3.1.1
proposed update for FC4 (currently updates-testing).  I'm going to close this
bug.  We do still have issues with the update manager (ie. bug 165225), but I
think (and correct me if I'm wrong) that this particular one can be closed.

Note You need to log in before you can comment on or make changes to this bug.