Bug 164132 - 'Cannot allocate memory' with /dev/cdrom
'Cannot allocate memory' with /dev/cdrom
Status: CLOSED DUPLICATE of bug 164062
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 03:33 EDT by Pavel
Modified: 2015-01-04 17:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-25 10:37:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel 2005-07-25 03:33:19 EDT
Description of problem:

Any operations with CDROM, such as, 'mount' or 'dd' - has result:

Cannot allocate memory

# mount /dev/cdrom /mnt/cdrom/
mount: Cannot allocate memory

# dd if=/dev/cdrom of=/home/user/CD.img
dd: opening `/dev/cdrom': Cannot allocate memory

Red Hat Enterprise Linux AS release 3 (Taroon Update 2)
Kernel 2.4.21-15.ELsmp on an i686

dmesg:

...
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 3191.7840 MHz.
..... host bus clock speed is 199.4865 MHz.
cpu: 0, clocks: 1994865, slice: 664955
CPU0<T0:1994864,T1:1329904,D:5,S:664955,C:1994865>
cpu: 1, clocks: 1994865, slice: 664955
CPU1<T0:1994864,T1:664944,D:10,S:664955,C:1994865>
cpu_sibling_map[0] = 1
cpu_sibling_map[1] = 0
mapping CPU#0's runqueue to CPU#1's runqueue.
zapping low mappings.
Process timing init...done.
Starting migration thread for cpu 0
Starting migration thread for cpu 1
PCI: PCI BIOS revision 2.10 entry at 0xf0031, last bus=4
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Ignoring BAR0-3 of IDE controller 00:1f.1
Transparent bridge - Intel Corp. 82801BA/CA/DB/EB PCI Bridge
PCI: Using IRQ router PIIX [8086/2640] at 00:1f.0
PCI->APIC IRQ transform: (B0,I2,P0) -> 16
PCI->APIC IRQ transform: (B0,I28,P0) -> 16
PCI->APIC IRQ transform: (B0,I29,P1) -> 19
PCI->APIC IRQ transform: (B0,I29,P2) -> 18
PCI->APIC IRQ transform: (B0,I29,P0) -> 23
PCI->APIC IRQ transform: (B0,I31,P0) -> 18
PCI->APIC IRQ transform: (B0,I31,P1) -> 19
PCI->APIC IRQ transform: (B0,I31,P1) -> 19
PCI->APIC IRQ transform: (B4,I3,P0) -> 27
PCI->APIC IRQ transform: (B1,I3,P0) -> 18
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS not found.
Total HugeTLB memory allocated, 0
Starting kswapd
allocated 32 pages and 32 bhs reserved for the highmem bounces
VFS: Disk quotas vdquot_6.5.1
aio_setup: num_physpages = 65017
aio_setup: sizeof(struct page) = 60
Hugetlbfs mounted.
pty: 2048 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ SER
IAL_PCI ISAPNP enabled
ttyS0 at 0x03f8 (irq = 4) is a 16550A
ttyS1 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10e
NET4: Frame Diverter 0.46
RAMDISK driver initialized: 256 RAM disks of 8192K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH6: IDE controller at PCI slot 00:1f.1
ICH6: chipset revision 3
ICH6: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xfff0-0xfff7, BIOS settings: hda:pio, hdb:DMA
    ide1: BM-DMA at 0xfff8-0xffff, BIOS settings: hdc:pio, hdd:pio
hdb: SONY CD-ROM CDU5212, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide-floppy driver 0.99.newide
ide-floppy driver 0.99.newide
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 8192 buckets, 64Kbytes
TCP: Hash tables configured (established 262144 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
Initializing IPsec netlink socket
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 301k freed
VFS: Mounted root (ext2 filesystem).
SCSI subsystem driver Revision: 1.00
megaide: driver version 05.08i (Date: October 20, 2004; 10:03 EST)
megaide: LD 0 RAID0 status=ONLINE 156114944 512-byte sectors (79931 MB) drives=1

megaide: LD 1 RAID0 status=ONLINE 1171603456 512-byte sectors (599861 MB) drives

=2
scsi0 : LSI Logic MegaIDE RAID BIOS Version 5.3.10081534, 8 targs 1 chans 8 luns

  Vendor: LSILOGIC  Model:  LD  0  IDERAID   Rev:
  Type:   Direct-Access                      ANSI SCSI revision: 02
  Vendor: LSILOGIC  Model:  LD  1  IDERAID   Rev:
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi disk sdb at scsi0, channel 0, id 1, lun 0
SCSI device sda: 156114944 512-byte hdwr sectors (79931 MB)
Partition check:
 sda: sda1 sda2
SCSI device sdb: 1171603456 512-byte hdwr sectors (599861 MB)
 sdb: sdb1
Journalled Block Device driver loaded
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 228k freed
EXT3 FS 2.4-0.9.19, 19 August 2002 on sd(8,1), internal journal
Adding Swap: 6369764k swap-space (priority -1)
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on sd(8,17), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
IA-32 Microcode Update Driver: v1.13 <tigran@veritas.com>
microcode: No suitable data for cpu 1
microcode: No suitable data for cpu 0
ip_tables: (C) 2000-2002 Netfilter core team
Intel(R) PRO/1000 Network Driver - version 5.2.30.1-k1
Copyright (c) 1999-2004 Intel Corporation.
divert: allocating divert_blk for eth0
eth0: Intel(R) PRO/1000 Network Connection
divert: allocating divert_blk for eth1
eth1: Intel(R) PRO/1000 Network Connection
ip_tables: (C) 2000-2002 Netfilter core team
ip_tables: (C) 2000-2002 Netfilter core team
e1000: eth0 NIC Link is Up 100 Mbps Half Duplex
smbfs: Unrecognized mount option noexec
smb_trans2_request: result=-104, setting invalid
smb_retry: successful, new pid=912, generation=2
...
smb_request: result -104, setting invalid
smb_retry: successful, new pid=912, generation=51
ide-floppy driver 0.99.newide
hdb: attached ide-cdrom driver.
hdb: ATAPI 40X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
smb_trans2_request: result=-104, setting invalid
smb_retry: successful, new pid=912, generation=52
udf: registering filesystem
inserting floppy driver for 2.4.21-15.ELsmp
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
EXT2-fs warning: checktime reached, running e2fsck is recommended
autofs: called with bogus options
ide-floppy driver 0.99.newide
hdb: attached ide-cdrom driver.
hdb: ATAPI 40X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver unloaded
ide-floppy driver 0.99.newide
hdb: attached ide-cdrom driver.
hdb: ATAPI 40X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
Uniform CD-ROM driver unloaded
ide-floppy driver 0.99.newide
hdb: attached ide-cdrom driver.
hdb: ATAPI 40X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
smb_request: result -104, setting invalid
smb_retry: successful, new pid=912, generation=53
smb_trans2_request: result=-104, setting invalid
smb_retry: successful, new pid=912, generation=54
end_request: I/O error, dev 02:00 (floppy), sector 0
smb_trans2_request: result=-104, setting invalid
smb_retry: successful, new pid=912, generation=55
...
Comment 1 Suzanne Hillman 2005-07-25 10:37:08 EDT

*** This bug has been marked as a duplicate of 164062 ***

Note You need to log in before you can comment on or make changes to this bug.