Bug 164133 - HP NX6125 very slow with 64 bit FC4
HP NX6125 very slow with 64 bit FC4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
http://forums.fedoraforum.org/showthr...
:
: 163981 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 04:49 EDT by peter young
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 18:41:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peter young 2005-07-25 04:49:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
Throttling is continually taking CPU down to 87%
The HP NX6125 goes very slow - to open a terminal sessions takes at least 10 seconds.

This is an HP laptop with AMD Turion processor.

It's OK under 32 bit version of FC4 but under AMD 64 bit this happens.

the messages file shows 

Jul 21 18:19:46 eult129 kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 18:19:46 eult129 kernel: shpchp: acpi_shpchprm:\_SB_.C046 evaluate _BBN fail=0x5
Jul 21 18:19:46 eult129 kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Jul 21 18:19:46 eult129 kernel: shpchp: acpi_shpchprm:\_SB_.C046 evaluate _BBN fail=0x5
Jul 21 18:19:46 eult129 kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC4 on any NX6125
2. Try and open a terminal session from Gnome or KDE
3.
  

Actual Results:  It takes at leats 10 seconds to open up

Expected Results:  Should take less than 1 second

Additional info:
Comment 1 peter young 2005-07-25 06:27:40 EDT
I think I've fixed it with the help of a colleague. The thermal trip settings 
were all set to 16 degrees C so throttling always occurred.

I have set the values to a higher level by modifiying 
the /etc/init.d /set_thermal file to contain these lines

	echo "95:75:75:65:60:55:45">/proc/acpi/thermal_zone/TZ1/trip_points
	echo "100:85:85:60:55:45">/proc/acpi/thermal_zone/TZ2/trip_points
	echo "100:55:55:60:55:45">/proc/acpi/thermal_zone/TZ3/trip_points

before the line
	touch /var/lock/subsys/set_thermal

Seems to be OK

Can you fix the kernel so that it has the values suggested for this machine by 
the manufacturer ?

I have just put in the unknown values taken from a completely different model.


Here are the trip_points beofre I made the mods

TZ1

critical (S5):           95 C
passive:                 16 C: tc1=1 tc2=2 tsp=100 devices=0xffff810057fc9d80
active[0]:               16 C: devices=0xffff810037e16680
active[1]:               16 C: devices=0xffff810037e16540
active[2]:               16 C: devices=0xffff810037e16480
active[3]:               16 C: devices=0xffff810037e16380

TZ2

critical (S5):           100 C
passive:                 16 C: tc1=1 tc2=2 tsp=300 devices=0xffff810057fc9d80

TZ3

critical (S5):           100 C
passive:                 16 C: tc1=1 tc2=2 tsp=300 devices=0xffff810057fc9d80
Comment 2 Dave Jones 2005-07-29 18:35:37 EDT
*** Bug 163981 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2005-07-29 18:41:17 EDT
That's a BIOS bug that HP need to fix.
As we've no idea about the validity of the values you've entered, we can't rely
on this workaround.

I suggest looking to see if theres a BIOS update available already, and if not,
somehow contact HP about this issue.
Comment 4 peter young 2005-08-16 11:20:15 EDT
I tried a BIOS upgrade which didn't help.
In fact the best cure is not the set_thermal above, but to set the kernel 
parameter no_timer_check=0 which fixes the fast clock problem on and this one.

Should I still report this to HP as an issue and if so what do they need to 
fix ?


Note You need to log in before you can comment on or make changes to this bug.