Bug 164175 - gtkmozembed.so has an old path to libgtkembedmoz.so
gtkmozembed.so has an old path to libgtkembedmoz.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 13:56 EDT by Guy Streeter
Modified: 2016-02-09 20:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-23 21:49:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guy Streeter 2005-07-25 13:56:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
gtkmozembed.so cannot locate libgtkembedmoz.so because it has a hard-coded path to an older mozilla version.

Version-Release number of selected component (if applicable):
gnome-python2-extras-2.10.0-2.1

How reproducible:
Always

Steps to Reproduce:
1. in python, "import gtkmozembed"
  

Actual Results:  ImportError: libgtkembedmoz.so: cannot open shared object file: No such file or directory


Expected Results:  The import should be successful.

Additional info:

$ strings /usr/lib/python2.4/site-packages/gtk-2.0/gtkmozembed.so|fgrep /usr/lib

/usr/lib/mozilla-1.7.6

mozilla is now at version 1.7.10. Simply rebuilding gnome-python2-extras resolves this problem.
Comment 1 Sergej Chodarev 2005-07-27 16:01:41 EDT
Adding file /etc/ld.so.conf.d/mozilla.conf with path to mozilla libraries
(/usr/lib/mozilla-1.7.10/) also resolves this problem.
Comment 2 Matthew Barnes 2006-09-23 21:49:23 EDT
The latest Rawhide package is working okay with the current Mozilla (1.7.13).
Closing this bug.

gnome-python2-extras-2.14.2-2.fc6

Note You need to log in before you can comment on or make changes to this bug.