Bug 164236 - 32bit dce/rpc app fails with ia32el service
32bit dce/rpc app fails with ia32el service
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ia32el (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-07-26 01:38 EDT by Vaibhav Khanduja
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0131
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:16:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dce installation rpm (341.16 KB, application/octet-stream)
2005-07-26 01:48 EDT, Vaibhav Khanduja
no flags Details
dce source (9.02 MB, application/octet-stream)
2005-07-26 01:51 EDT, Vaibhav Khanduja
no flags Details
btlib's patch to solve the failure of socket calls (1.93 KB, patch)
2005-08-15 07:09 EDT, Yoav Zach
no flags Details | Diff

  None (edit)
Description Vaibhav Khanduja 2005-07-26 01:38:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
The 32 bit dce/rpc application fails to communicate when ia32el service is up. It seems the udp communication is failing. The dce/rpc comunication package used by us is from the same branch as freedce https://sourceforge.net/projects/freedce/.
I would also be attaching the our dce with this bug.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
The dce.rpc and src.tar.gz would be attached with this bug.
Follow following steps to reproduce the issue

1) Install dce.rpm 

2) execute following to stop rpcd daemon started by installation of dce.rpm
  
   a)  /etc/init.d/rc.dce-clean start
    
   b)  /etc/init.d/rc.dcerpcd  stop

3) The sources is also attached do an untar of these in /opt directory. This is the same directory where dce is installed.

4) Go to /opt/src and source .env file

5) export env variable LD_ASSUME_KERNEL=2.4.19. We do that because we compile our code with LinuxThreads. But the issue is seen otherwise too, if LD_ASSUME_KERNLE is not exported.

6) goto /opt/src/rpc/rpcd and execute ./rpcd. Do a ps -eaf | grep -i rpcd to see instances of rpcd are up.

7) goto /opt/src/demos/echo_server and execute ./echo_server&. This is the sample rpc server which registers its mapping with rpcd. It registers both tcp and udp mapping. What I see here is tcp mapping is happening but not upd. The source code of this is also present.

8) If echo_server is able to register mapping execute ./echo_client

This works perfectly fine with RHEL 3.0 ia64 with ia32el service not up. But as we know on RHEL 4.0 we need to bring up ia32el service as a result issue is seen. 
I am quite sure this is a issue with ia32el because on Suse enterprise Linux 9.0 when the service was up  rpc communication fails but not when the service is down.



  

Actual Results:  dce/rpc communication fails

Expected Results:  dce/rpc communication should have worked.

Additional info:
Comment 1 Vaibhav Khanduja 2005-07-26 01:48:56 EDT
Created attachment 117141 [details]
dce installation rpm
Comment 2 Vaibhav Khanduja 2005-07-26 01:52:07 EDT
Created attachment 117143 [details]
dce source
Comment 3 Vaibhav Khanduja 2005-07-27 09:12:13 EDT
There has been no update on this since I filed the case. Can anybody please 
update me on this?
Comment 4 Yoav Zach 2005-07-27 09:58:55 EDT
We (Intel's IA32EL team) made the repro, and we're analyzing it now. I just 
don't know how to change the status of this entry to 'assigned', otherwise I 
would do it before.

Thanks,
Yoav.
Comment 5 Yoav Zach 2005-08-15 07:09:08 EDT
Created attachment 117740 [details]
btlib's patch to solve the failure of socket calls
Comment 6 Yoav Zach 2005-08-15 07:13:31 EDT
We believe we found the problem and fixed it. We would like to have your help 
verifying the fix before we check it into our codebase. Attached please find a 
patch to ia32el sources. It may shout about original line numbers, as I don't 
know which ia32el version you have. Can you please apply this patch and test 
with it ?
The source RPM of ia32el resides on the extra CD (LACD), the same CD as the 
binary RPM. In case you have problems patching and building ia32el please 
contact me directly at yoav.zach@intel.com, and I'll send a detailed 
instructions for doing it.

Thanks,
Yoav.
Comment 7 Yoav Zach 2005-08-21 03:40:50 EDT
HP - any news ? time is running short for U7 deadline.

Thanks,
Yoav.
Comment 8 Vaibhav Khanduja 2005-08-22 00:54:37 EDT
Sorry for the delay I was bit busy in training so could not do it. I would be
working on this today. May it is a good idea for you send me the tar balls of
the compiled code I would test it out here. That would be faster.

Do let me know. 

Thanks,
Vaibhav Khanduja
Comment 10 Vaibhav Khanduja 2005-08-24 07:11:48 EDT
Hi Yoav,

First of all I would like to thanks you for helping me out here by sending
instruction of how to build the patch. I am able to succesfully complete the
compilation and installation. 

Further to that I have also done testing with my sample application and the
problem is not seen. I am able to register my UDP mapping with rpcd daemon and
have the communication up. 

Next step would be to certify/test HP's application on the system to be sure
everything is working fine. I would be able to get back to by end this month.

I have tested this on RHEL 4.0 and would be testing further on SUSE linux too.
Let me know if same bins would work there or not?
Apart from this I would like you to send me information of the exact version in
which this patch would be released. This information is needed since we would
like to provide the same to our customers.


Thank you very much
Vaibhav Khanduja
HP ISO,
Bangalore.
Comment 11 Vaibhav Khanduja 2005-08-24 07:12:33 EDT
Hi Yoav,

First of all I would like to thanks you for helping me out here by sending
instruction of how to build the patch. I am able to succesfully complete the
compilation and installation. 

Further to that I have also done testing with my sample application and the
problem is not seen. I am able to register my UDP mapping with rpcd daemon and
have the communication up. 

Next step would be to certify/test HP's application on the system to be sure
everything is working fine. I would be able to get back to by end this month.

I have tested this on RHEL 4.0 and would be testing further on SUSE linux too.
Let me know if same bins would work there or not?
Apart from this I would like you to send me information of the exact version in
which this patch would be released. This information is needed since we would
like to provide the same to our customers.


Thank you very much
Vaibhav Khanduja
HP ISO,
Bangalore.
Comment 12 Yoav Zach 2005-08-24 08:01:30 EDT
I'm glad to hear that. It's good news.
As for your questions -
*) same binaries should work for all OS versions
*) the fix will be released with the next OS updates, i.e. - RHEL3/U7 RHEL4/U3 
SLES9/SP3

And I have a request, too - please don't give this patched version of ia32el to 
customers, as this is an ad-hoc version, which was not validated properly.

Please let us about your finding running HP's application when you have them.

Thanks,
Yoav.
Comment 13 Vaibhav Khanduja 2005-08-24 09:21:48 EDT
The reason why I asked for the release patch version is because we would be
providing our customers with that version details. There is no way I would be
forwarding the same adhoc version.

Thanks,
Vaibhav Khanduja
Comment 20 Red Hat Bugzilla 2006-03-07 13:16:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0131.html

Note You need to log in before you can comment on or make changes to this bug.