Bug 164241 - mount doesn't support noacl option with nfs
mount doesn't support noacl option with nfs
Status: CLOSED DUPLICATE of bug 164240
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-26 02:20 EDT by Panu Matilainen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-26 02:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panu Matilainen 2005-07-26 02:20:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/ref-guide/s1-nfs-client-config.html states "noacl — Turns off all ACL processing. This may be needed when interfacing with older versions of Red Hat Enterprise Linux, Red Hat Linux, or Solaris, since the most recent ACL technology is not compatible with older systems."

In RHEL 3 this used to work, except it was called no_acl, not noacl like the documentation says. In RHEL 4 it doesn't, and in certain environments the ACL's cause a significant slowdown (enormous amount of ACCESS operations)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mount -o noacl localhost:/some/path /mnt

  

Actual Results:  [root@lizilla ~]# mount -o noacl localhost:/tmp /mnt
Unsupported nfs mount option: noacl
[root@lizilla ~]# mount -o no_acl localhost:/tmp /mnt
Unsupported nfs mount option: no_acl


Expected Results:  It should have nfs-mounted the directory with ACL support off.

Additional info:
Comment 1 Panu Matilainen 2005-07-26 02:22:10 EDT
Oops, sorry about the dupe...

*** This bug has been marked as a duplicate of 164240 ***

Note You need to log in before you can comment on or make changes to this bug.