Bug 164245 - wrong encoding in .desktop entry
wrong encoding in .desktop entry
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
: 164246 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-26 03:52 EDT by Andrew Martynov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.0.0-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 04:42:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot of GNOME menu (179.59 KB, image/png)
2005-07-26 03:56 EDT, Andrew Martynov
no flags Details
patch for correction desktop menu entry (582 bytes, patch)
2005-07-26 04:21 EDT, Andrew Martynov
no flags Details | Diff
correction for menu item (Russian) (582 bytes, patch)
2005-07-26 04:24 EDT, Andrew Martynov
no flags Details | Diff

  None (edit)
Description Andrew Martynov 2005-07-26 03:52:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

Description of problem:
After install the package coresponding menu item is shown in wrong encoding.


Version-Release number of selected component (if applicable):
system-config-bind-4.0.0-19_FC5

How reproducible:
Always

Steps to Reproduce:
1. install system-config-bind from RAWHIDE
2. start new X session with Russian language
3. look into menu "Системные параметры/Настройка сервера/"
  

Actual Results:  look into screen-shot image

Expected Results:  Utility name in Russian

Additional info:

I found that system-config-bind.desktop file was generated from translations of bindconf, which was in 8bit encoding for Russian (and some other languages). So wrong encoding conversion was occured. 

The best way is to include translatable string from system-config-bind.desktop file into .pot and allows translators correct utility names.

While regeneration desktop file translation made by hand in ru.po is included into  .desktop for package so problem in .pot file generation.
Comment 1 Andrew Martynov 2005-07-26 03:56:02 EDT
Created attachment 117146 [details]
screen-shot of GNOME menu
Comment 2 Andrew Martynov 2005-07-26 04:21:10 EDT
Created attachment 117147 [details]
patch for correction desktop menu entry
Comment 3 Andrew Martynov 2005-07-26 04:24:44 EDT
Created attachment 117148 [details]
correction for menu item (Russian)

Previous patch was "reverse patch"
Comment 4 Andrew Martynov 2005-07-26 04:27:38 EDT
*** Bug 164246 has been marked as a duplicate of this bug. ***
Comment 5 Jason Vas Dias 2005-07-26 14:53:06 EDT
This is now fixed with current version in CVS (system-config-bind-4.0.0-21).
The desktop file strings were added to all .po files and the .po file, and 
the desktop file is now re-built during the build from strings in the .po 
files. Translators are responsible for ensuring the 'system-config-bind.desktop'
strings are OK.


  

Note You need to log in before you can comment on or make changes to this bug.