Bug 164336 - Cannot start up with dmraid partition entries in /etc/fstab
Cannot start up with dmraid partition entries in /etc/fstab
Status: CLOSED DUPLICATE of bug 151585
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dmraid (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-26 21:36 EDT by Suzuki Takashi
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-27 08:20:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzuki Takashi 2005-07-26 21:36:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When I have a mount entry for /dev/dm-0 in /etc/fstab,
the startup script complains that /dev/dm-0 doesn't exist and 
prompts root's password.
The message was something like:
*** An error occurred during the file system check.
*** Dropping you to a shell; the system will reboot
*** when you leave the shell.

If I set a noauto option to the fstab entry, or just comment it out, 
things are ok except the partition is not mounted at all.

The relevant fstab entry is:
/dev/dm-0               /work                   ext3    defaults        1 2


Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc6.1-3_RHEL4_U1

How reproducible:
Always

Steps to Reproduce:
1. Add and set up a ATARAID card with hard drives.
2. Boot.
3. Check if the ATARAID is properly configured by `dmraid -cccs.'
4. Enable it with `dmraid -ay.'
5. Create a partition into /dev/dm-0.
6. Add a mount entry for /dev/dm-0 to /etc/fstab.
7. Reboot.


Actual Results:  Stop during startup and cannot be logged in, etc. any more.


Expected Results:  Startup finishes and /dev/dm-0 is correctly mounted to /work.


Additional info:

My ATARAID card is Promise FastTrak TX2000 and correctly detected as following:
# /sbin/dmraid -cccs
pdc_dhiibgdi:585937500:128:mirror:ok:0:2:0
/dev/hde:pdc:pdc_dhiibgdi:mirror:ok:585937500:0
/dev/hdg:pdc:pdc_dhiibgdi:mirror:ok:585937500:0
Comment 1 Suzuki Takashi 2005-07-26 21:44:11 EDT
There should be a dmraid enable action in the startup scripts like:
# dmraid initialization
action $"Setting up dmraid:" /sbin/dmraid -ay

When I added the lines above into rc.sysinit, 
just after LVM initialization action, 
startup came to be finished and the partition was properly mounted.

But I don't know if the location is best or 
how to test if any dmraid devices exist before running /sbin/dmraid, 
which might be necessary.
Comment 2 Heinz Mauelshagen 2005-07-27 08:20:01 EDT
This will be covered by adding installer support to Anaconda and enhancements to
the initscripts, which are in the works already.

*** This bug has been marked as a duplicate of 151585 ***

Note You need to log in before you can comment on or make changes to this bug.