Bug 164337 - radeonfb oopses
radeonfb oopses
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-26 21:41 EDT by Bill Nottingham
Modified: 2015-01-04 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 21:41:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-07-26 21:41:36 EDT
radeonfb: Retreived PLL infos from BIOS
radeonfb: Reference=27.00 MHz (RefDiv=12) Memory=252.00 Mhz, System=200.00 MHz
radeonfb: PLL min 20000 max 35000
Non-DDC laptop panel detected
radeonfb: Monitor 1 type LCD found
radeonfb: Monitor 2 type no found
radeonfb: panel ID string: SXGA+ Single (85MHz)
radeonfb: detected LVDS panel size from BIOS: 1400x1050
radeondb: BIOS provided dividers will be used
radeonfb: Dynamic Clock Power Management enabled
radeonfb: forcefully enabling sleep mode
Unable to handle kernel paging request at virtual address fffffff6
 printing eip:
c02311f1
*pde = 00002067
Oops: 0000 [#1]
Modules linked in: radeonfb i2c_algo_bit nfs lockd nfs_acl tun arc4
ieee80211_crypt_wep radeon drm loop parport_pc lp parport ipv6 autofs4 sunrpc
ipt_REJECT ipt_state ip_conntrack iptable_filter ip_tables dm_mod video button
battery ac pcmcia yenta_socket rsrc_nonstatic pcmcia_core uhci_hcd ehci_hcd
shpchp hw_random i8xx_tco i2c_i801 i2c_core snd_intel8x0m snd_intel8x0
snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore
snd_page_alloc e1000 ipw2200 ieee80211 ieee80211_crypt ext3 jbd
CPU:    0
EIP:    0060:[<c02311f1>]    Not tainted VLI
EFLAGS: 00010246   (2.6.12-1.1435_FC5)
EIP is at fb_set_logocmap+0x79/0xee
eax: 00000020   ebx: fffffff6   ecx: 00000000   edx: 00000010
esi: 00000000   edi: 00000010   ebp: 00000000   esp: ef26bc2c
ds: 007b   es: 007b   ss: 0068
Process modprobe (pid: 25357, threadinfo=ef26b000 task=f1b0b000)
Stack: c045f154 eb944000 00000008 00000282 00000002 00000004 d67c2208 eb944000
       00000007 00000000 00000000 f90d8000 00000010 00000001 c015cca3 d67c21f4
       de3bcb10 00ffffff 00ffff00 00000000 00000010 c04a4c60 c04a4c40 f8c03a85
Call Trace:
 [<c015cca3>] poison_obj+0x20/0x3d
 [<f8c03a85>] radeonfb_setcmap+0xc7/0x4b9 [radeonfb]
 [<c023180d>] fb_show_logo+0x1af/0x1f5
 [<c02306ce>] bit_clear_margins+0xa2/0xdb
 [<c022eaa5>] fbcon_switch+0x474/0x4c4
 [<c026f110>] redraw_screen+0xab/0x1ba
 [<c026e8df>] update_attr+0x8c/0x9d
 [<c02720eb>] take_over_console+0x26f/0x35a
 [<c015eac7>] cache_alloc_refill+0xc8/0x389
 [<c01d5113>] sysfs_make_dirent+0x13/0x81
 [<c015cca3>] poison_obj+0x20/0x3d
 [<c022b4db>] fbcon_takeover+0x69/0xa0
 [<c0135799>] notifier_call_chain+0x17/0x27
 [<c0232553>] register_framebuffer+0xd3/0x181
 [<c012df54>] process_timeout+0x0/0x5
 [<c012e334>] msleep+0x30/0x38
 [<f8c0c9d4>] radeon_pm_enable_dynamic_mode+0x1ce6/0x28c9 [radeonfb]
 [<c01227a5>] printk+0x1b/0x1f
 [<f8c07f6b>] radeonfb_pci_register+0x2e7/0x54b [radeonfb]
 [<c0216af0>] kobject_hotplug+0x2a4/0x39e
 [<c0223494>] __pci_device_probe+0x30/0x3d
 [<c02234bf>] pci_device_probe+0x1e/0x35
 [<c0291a3d>] driver_probe_device+0x35/0x9e
 [<c0291b58>] __driver_attach+0x45/0x47
 [<c02912f5>] bus_for_each_dev+0x3c/0x5a
 [<c0291b70>] driver_attach+0x16/0x1a
 [<c0291b13>] __driver_attach+0x0/0x47
 [<c02916be>] bus_add_driver+0x66/0xaf
 [<c02236a4>] pci_register_driver+0x97/0xb7
 [<c01486c4>] sys_init_module+0xca/0x1c4
 [<c0103b15>] syscall_call+0x7/0xb
Code: 31 d2 89 c7 29 d7 89 fa 83 ff 10 7e 0a bf 10 00 00 00 ba 10 00 00 00 8d 45
20 89 44 24 68 89 54 24 6c 85 ff 7e 53 31 f6 8d 0c 36 <0f> b6 03 89 c2 c1 e2 08
66 0f b6 c0 09 c2 8b 44 24 70 66 89 14

2.6.12-1.1435_FC5
Comment 1 Warren Togami 2005-09-08 00:57:37 EDT
Thinkpad T41 2373HU6
kernel-2.6.12-1.1451_FC4
xorg-x11-6.8.2-37.FC4.45

The following oops happened during loading radeonfb while X was running with
maybe 24 hours uptime.  I was unable to reproduce the oops after rebooting. 
Enabled/disabled radeonfb radeon_force_sleep=1 made no difference in subsequent
tests.

radeonfb: Unknown parameter `'
ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
radeonfb: Retreived PLL infos from BIOS
radeonfb: Reference=27.00 MHz (RefDiv=12) Memory=260.00 Mhz, System=183.00 MHz
radeonfb: PLL min 12000 max 35000
Non-DDC laptop panel detected
radeonfb: Monitor 1 type LCD found
radeonfb: Monitor 2 type no found
radeonfb: panel ID string: 1024x768
radeonfb: detected LVDS panel size from BIOS: 1024x768
radeondb: BIOS provided dividers will be used
radeonfb: Dynamic Clock Power Management enabled
radeonfb: forcefully enabling sleep mode
Unable to handle kernel paging request at virtual address 72000001
 printing eip:
c022a0de
*pde = 00000000
Oops: 0000 [#1]
Modules linked in: radeonfb i2c_algo_bit loop parport_pc lp parport autofs4
sunrpc dm_mod video button battery ac yenta_socket rsrc_nonstatic pcmcia_core
uhci_hcd ehci_hcd shpchp i2c_i801 i2c_core snd_intel8x0m snd_intel8x0
snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore
snd_page_alloc e1000 aes_i586 airo joydev ext3 jbd
CPU:    0
EIP:    0060:[<c022a0de>]    Not tainted VLI
EFLAGS: 00210246   (2.6.12-1.1451_FC4)
EIP is at fb_set_logocmap+0x79/0xee
eax: 00000020   ebx: 72000001   ecx: 00000000   edx: 00000010
esi: 00000000   edi: 00000010   ebp: 00000000   esp: c97f8c44
ds: 007b   es: 007b   ss: 0068
Process modprobe (pid: 967, threadinfo=c97f8000 task=dc9bf550)
Stack: c044cef4 f4352000 c97f8c64 c011b20f c045cc40 00000002 c03cccb4 c1139400
       000000d0 00000002 c1231a00 c03ccf60 c03cccb4 c03ccf60 f7fffdc0 00000002
       00000080 00000030 c0226f0c c0226f5f 00000300 00000001 f4352008 f4352000
Call Trace:
 [<c011b20f>] activate_task+0x56/0x65
 [<c0226f0c>] fbcon_resize+0x0/0x3b5
 [<c0226f5f>] fbcon_resize+0x53/0x3b5
 [<c022a6fa>] fb_show_logo+0x1af/0x1f5
 [<f8b3d731>] radeonfb_pan_display+0x0/0x97 [radeonfb]
 [<c022773b>] fbcon_switch+0x47a/0x4c8
 [<c0268790>] redraw_screen+0xab/0x1ba
 [<c0267f5f>] update_attr+0x8c/0x9d
 [<c026b76b>] take_over_console+0x26f/0x35a
 [<c01cf9fb>] sysfs_make_dirent+0x13/0x81
 [<c0224084>] fbcon_takeover+0x69/0xa0
 [<c0135589>] notifier_call_chain+0x17/0x27
 [<c022b443>] register_framebuffer+0xd3/0x181
 [<c012e128>] msleep+0x5d/0x65
 [<f8b479f4>] radeon_pm_enable_dynamic_mode+0x1ce6/0x28c9 [radeonfb]
 [<c0121b78>] printk+0x1b/0x1f
 [<f8b42f87>] radeonfb_pci_register+0x313/0x577 [radeonfb]
 [<c021c390>] pci_device_probe_static+0x25/0x31
 [<c021c3bc>] __pci_device_probe+0x20/0x30
 [<c021c3e7>] pci_device_probe+0x1b/0x32
 [<c028a717>] driver_probe_device+0x21/0x55
 [<c028a83e>] driver_attach+0x4f/0x85
 [<c020fb58>] kobject_register+0x2e/0x59
 [<c028ac4c>] bus_add_driver+0x8a/0xb7
 [<c021c5ad>] pci_register_driver+0x89/0xac
 [<c014889c>] sys_init_module+0xca/0x1c4
 [<c0103a61>] syscall_call+0x7/0xb
Code: 31 d2 89 c7 29 d7 89 fa 83 ff 10 7e 0a bf 10 00 00 00 ba 10 00 00 00 8d 45
20 89 44 24 68 89 54 24 6c 85 ff 7e 53 31 f6 8d 0c 36 <0f> b6 03 89 c2 c1 e2 08
66 0f b6 c0 09 c2 8b 44 24 70 66 89 14


Comment 2 Dave Jones 2005-10-06 02:47:27 EDT
stil happening with latest errata? 
Comment 3 Bill Nottingham 2005-10-06 21:41:41 EDT
No.

Note You need to log in before you can comment on or make changes to this bug.