Bug 164340 - unexpected identifier `gtk-alternative-button-order', compat gtk+ mixing problem
Summary: unexpected identifier `gtk-alternative-button-order', compat gtk+ mixing problem
Status: CLOSED DUPLICATE of bug 164065
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-27 02:16 UTC by D. Stimits
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 10:16:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description D. Stimits 2005-07-27 02:16:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050319

Description of problem:
KDE contains code to deal with gtk applications. On FC4, with both gtk2-2.6.7-4 and compat version gtk+-1.2.10-39, using some gtk 1.2 apps results in:
/home/username/.kde/share/config/gtkrc:37: error: unexpected identifier `gtk-alternative-button-order', expected keyword - e.g. `style'

Note that this is generated by KDE because it is the .kde per-user config area. Apparently KDE does not deal properly with config of mixed 1.2 and 2.6 gtk apps.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install both gtk 1.2 and gtk 2.6 on FC4.
2. Some gtk 1.2 apps will generate this message when run from KDE.
3. Deleting this line from the file fixes the problem temporarily, but the line is sometimes regenerated.
  

Actual Results:  Gtk 1.2 apps will sometimes generate an error when run from KDE, stating:
~/.kde/share/config/gtkrc:37: error: unexpected identifier `gtk-alternative-button-order', expected keyword - e.g. `style'

Expected Results:  No error. If gtkrc is to be modified, it should modify gtk-alternative-button-order with proper arguments for gtk 1.2 apps.

Additional info:

Comment 1 Walter Justen 2005-08-26 10:16:15 UTC
Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 164065 ***


Note You need to log in before you can comment on or make changes to this bug.