Bug 164486 - Update breaks clock
Update breaks clock
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
4
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
: 164603 164690 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 03:09 EDT by David L.
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.25.3-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 09:16:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David L. 2005-07-28 03:09:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The recent update util-linux-2.12p-9.7 causes an anomalous time shift of an
extra (UTC-local time). My hardware clock is set to local time and this is reflected in the system-config-date settings.

If I change the setting to Hardware clock is UTC then there is a
2*(UTC-local time) shift.

Everything was fine in util-linux-2.12p-9.5 and reverting to that fixes the problem (at least once the clock is set back to the correct time).

Version-Release number of selected component (if applicable):
util-linux-2.12p-9.7

How reproducible:
Always

Steps to Reproduce:
1. See above
2.
3.
  

Additional info:
Comment 1 Karel Zak 2005-07-28 05:53:05 EDT
I would like you to exactly describe how I can reproduce it. It means sys clock
and hw clock (date; hwclock --show) before and after the change and exact
command  which you use for the hwclock change. Thanks.
Comment 2 David L. 2005-07-28 09:03:16 EDT
I applied the new audit, audit-libs update which may have changed what I was
seeing somewhat, but the basic problem is there. Upshot is the problem goes away
for selinux permissive, but is there for selinux enforcing.

Steps to reproduce:

selinux is set to enforcing. util-linux is version 2.12p-9.5

hwclock
Thu 28 July 2005 08:08:34 AM EDT  -0.519677 seconds
date
Thu July 28 08:08:39 EDT 2005

After updating util-linux to 2.12p-9.7 and reboot and check clock is correct
in bios setup screen

hwclock
Error- unable to connect to audit system
date
Thu July 28 04:10:21 EDT 2005

Set selinux to permissive and reboot and check clock is correct in bios setup

hwclock
Thu 28 July 2005 08:13:34 AM EDT  -0.995734 seconds
date
Thu July 28 08:13:38 EDT 2005
Comment 3 Bert DeKnuydt 2005-07-28 09:08:08 EDT
I have possibly something related:

This is with kernel-smp-2.6.12-1.1398_FC4 & util-linux-2.12p-9.7 on a
Dell OptiPlex GX280.

> hwclock --show
select() to /dev/rtc to wait for clock tick timed out

This has as a side effect, that after cold booting the clock on that machine
is off by two hours.

However this works:

>hwclock --show --directisa
Thu 28 Jul 2005 02:59:44 PM CEST  -0.362036 seconds

Strangely enough, on an another GX280 (few months older) with identical software
configuration, I don't have this problem
Comment 7 Daniel Walsh 2005-07-28 12:45:04 EDT
Fixed in selinux-policy-targetd-1.25.3-9
Comment 8 Steve Grubb 2005-07-29 06:45:08 EDT
*** Bug 164603 has been marked as a duplicate of this bug. ***
Comment 9 Jonathan S. Shapiro 2005-08-01 00:35:22 EDT
Daniel: any idea when this update will be pushed? It's screwing up audit logs
all over the place...
Comment 10 Karel Zak 2005-08-01 04:15:32 EDT
*** Bug 164690 has been marked as a duplicate of this bug. ***
Comment 11 Karel Zak 2005-08-01 04:23:18 EDT
*** Bug 164693 has been marked as a duplicate of this bug. ***
Comment 12 Daniel Walsh 2005-08-01 08:10:38 EDT
Pushed today, should be out tomorrow.
Comment 13 Need Real Name 2005-08-02 08:11:09 EDT
I have the new policy installed - selinux-policy-targeted-1.25.3-9 - and am
finding hwclock --show gives no output, as with the previous policy - the only
difference is that no errors now show up in audit.log when in enforcing mode
now. Set in permissive mode, hwclock shows output. Ideas?

#~> rpm -q selinux-policy-targeted util-linux
selinux-policy-targeted-1.25.3-9
util-linux-2.12p-9.7
teapot#~> date; hwclock --show
Tue Aug  2 13:08:38 BST 2005
#~> setenforce 0
#~> date; hwclock --show
Tue Aug  2 13:08:45 BST 2005
Tue 02 Aug 2005 01:08:46 PM BST  -0.223150 seconds
#~> setenforce 1
Comment 14 Jerry 2005-08-06 03:03:32 EDT
I am getting the following with latest updates:  suggestions?

audit(1123265259.544:2): avc:  denied  { create } for  pid=1645 comm="hwclock"
scontext=system_u:system_r:hwclock_t tcontext=system_u:system_r:hwclock_t
tclass=netlink_audit_socket
audit(1123290458.999:3): avc:  denied  { write } for  pid=1645 comm="hwclock"
scontext=system_u:system_r:hwclock_t tcontext=system_u:system_r:hwclock_t
tclass=netlink_audit_socket
audit(1123290459.000:4): avc:  denied  { nlmsg_relay } for  pid=1645
comm="hwclock" scontext=system_u:system_r:hwclock_t
tcontext=system_u:system_r:hwclock_t tclass=netlink_audit_socket
audit(1123290459.000:5): avc:  denied  { read } for  pid=1645 comm="hwclock"
scontext=system_u:system_r:hwclock_t tcontext=system_u:system_r:hwclock_t
tclass=netlink_audit_socket
Comment 15 Daniel Walsh 2005-08-07 05:49:21 EDT
Update to 	selinux-policy-targeted-1.25.3-12

Note You need to log in before you can comment on or make changes to this bug.