Bug 164490 - Crash on posting to usenet
Crash on posting to usenet
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 04:37 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-25 09:04:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-07-28 04:37:41 EDT
Description of problem:
Evolution crashes on trying to post to usenet

Version-Release number of selected component (if applicable):
2.3.5.1-1

How reproducible:
Always

Steps to Reproduce:
1. Write something to a usenet group
2.
3.
  
Actual results:
Backtrace was generated from '/usr/bin/evolution'

Using host libthread_db library "/lib/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1208572240 (LWP 2842)]
[New Thread -1360024656 (LWP 2858)]
[New Thread -1349534800 (LWP 2857)]
[New Thread -1339044944 (LWP 2856)]
[New Thread -1318065232 (LWP 2854)]
[New Thread -1293476944 (LWP 2852)]
[New Thread -1282987088 (LWP 2850)]
[New Thread -1257641040 (LWP 2849)]
[New Thread -1247147088 (LWP 2846)]
[New Thread -1236657232 (LWP 2845)]
[New Thread -1226167376 (LWP 2844)]
0x00d78402 in __kernel_vsyscall ()
#0  0x00d78402 in __kernel_vsyscall ()
#1  0x00c5cfcb in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x074cf2ad in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  0x0805f68a in segv_redirect (sig=11) at main.c:424
#4  <signal handler called>
#5  0x00d78402 in __kernel_vsyscall ()
#6  0x00ba410c in poll () from /lib/libc.so.6
#7  0x071579d8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#8  0x07157e73 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#9  0x07236625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#10 0x0805fb06 in main (argc=63, argv=0xbffa50b4) at main.c:602

Thread 11 (Thread -1226167376 (LWP 2844)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x06662117 in e_msgport_wait (mp=0x91d5748) at e-msgport.c:511
	msg = 
Thread 10 (Thread -1236657232 (LWP 2845)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x06662117 in e_msgport_wait (mp=0x91d5748) at e-msgport.c:511
	msg = 
Thread 9 (Thread -1247147088 (LWP 2846)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x06662117 in e_msgport_wait (mp=0x91d2bc0) at e-msgport.c:511
	msg = 
Thread 8 (Thread -1257641040 (LWP 2849)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c5be8e in __lll_mutex_lock_wait () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00c58bb5 in _L_mutex_lock_36 () from /lib/libpthread.so.0
No symbol table info available.
#3  0x00c5a56f in pthread_kill () from /lib/libpthread.so.0
No symbol table info available.
#4  0x0805f67a in segv_redirect (sig=11) at main.c:433
No locals.
#5  <signal handler called>
No symbol table info available.
#6  0x0472b052 in send_queue_send (mm=0x9ab0ec8) at mail-ops.c:569
	sent_folder = (CamelFolder *) 0x921eda0
	uids = (GPtrArray *) 0x9a4133c
	send_uids = (GPtrArray *) 0x9a413b4
	ex = {id = CAMEL_EXCEPTION_NONE, desc = 0x0}
	i = 
Thread 7 (Thread -1282987088 (LWP 2850)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c5cfcb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00ab3690 in pipe_to_sa_full (msg=0x9ab1de4, in=0x0, argv=0xb3872110, 
    rv_err=0, wait_for_termination=1, output_buffer=0x0)
    at em-junk-filter.c:205
	maxfd = 
Thread 6 (Thread -1293476944 (LWP 2852)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x06662117 in e_msgport_wait (mp=0x91d56f0) at e-msgport.c:511
	msg = 
Thread 5 (Thread -1318065232 (LWP 2854)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x06662117 in e_msgport_wait (mp=0x91d5748) at e-msgport.c:511
	msg = 
Thread 4 (Thread -1339044944 (LWP 2856)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00ba68d1 in ___newselect_nocancel () from /lib/libc.so.6
No symbol table info available.
#2  0x0672af2b in camel_read (fd=63, buf=0xa0bd498 "\n»À", n=4096)
    at camel-file-utils.c:419
	tv = {tv_sec = 215, tv_usec = 996000}
	res = -514
	errnosav = 
Thread 3 (Thread -1349534800 (LWP 2857)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x06662117 in e_msgport_wait (mp=0x91d5748) at e-msgport.c:511
	msg = 
Thread 2 (Thread -1360024656 (LWP 2858)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c597b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x06662117 in e_msgport_wait (mp=0x91d5748) at e-msgport.c:511
	msg = 
Thread 1 (Thread -1208572240 (LWP 2842)):
#0  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c5cfcb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x074cf2ad in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  0x0805f68a in segv_redirect (sig=11) at main.c:424
No locals.
#4  <signal handler called>
No symbol table info available.
#5  0x00d78402 in __kernel_vsyscall ()
No symbol table info available.
#6  0x00ba410c in poll () from /lib/libc.so.6
No symbol table info available.
#7  0x071579d8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x07157e73 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x07236625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#10 0x0805fb06 in main (argc=63, argv=0xbffa50b4) at main.c:602
	fd = 

Expected results:
Post should be fine

Additional info:
Comment 1 Paul F. Johnson 2005-07-28 19:23:49 EDT
When I run evolution from the command line, the following is also thrown back.
No idea how useful it is.

[paul@T7 ~]$ evolution
es menu class init
adding hook target 'source'

(evolution:26600): evolution-mail-WARNING **: couldn't get service : No provider
available for protocol `'

(evolution:26600): Gdk-CRITICAL ** : gdk_gc_set_foreground: assertion `GDK_IS_GC
(gc)' failed
BBDB spinning up...

(evolution:26600): e-data-server-ui-WARNING **: ENameSelectorDialog failed to
open book!

(evolution:26600): camel-WARNING **: camel_exception_get_id called with NULL
parameter.
Variable "i" is not available
Variable "msg" is not available (repeated 6 times in total)
Variable "loop" is not available
Variable "fd" is not available
Comment 2 Paul F. Johnson 2005-07-29 15:12:52 EDT
This is getting odd. If I don't hit send/recieve, but leave Ev to it's own
devices, the posting is made (okay, it has to restart after I originally write
the post). The posting stays in my outgoing folder and if I do a manual send and
recieve, Ev dies.

It looks like possibly the problem is also associated with the send / receive
window.

Using evolution 2.3.6-1
Comment 3 Paul F. Johnson 2005-07-31 08:07:10 EDT
Still there in 2.3.6.1-2
Comment 4 Paul F. Johnson 2005-08-07 06:30:17 EDT
WORKAROUND - simple enough, put an address in the TO: box and the software
doesn't crash.
Comment 5 Paul F. Johnson 2005-08-10 21:36:11 EDT
Update : Workaround no longer works in version 2.3.7-1.
Comment 6 Dave Malcolm 2005-08-10 21:57:53 EDT
Thanks for the updates.

Looking at the original backtrace, it looks like the crash is in mail-ops.c:
send_queue_send

Please can you ensure that both up-to-date evolution-debuginfo and
evolution-data-server-debuginfo packages are installed and attach a fresh
backtrace.  Thanks.
Comment 7 Paul F. Johnson 2005-08-11 03:17:46 EDT
As requested

Backtrace was generated from '/usr/bin/evolution'

Using host libthread_db library "/lib/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1209014608 (LWP 12315)]
[New Thread -1336996944 (LWP 12334)]
[New Thread -1301308496 (LWP 12333)]
[New Thread -1311798352 (LWP 12330)]
[New Thread -1269838928 (LWP 12329)]
[New Thread -1290818640 (LWP 12326)]
[New Thread -1280328784 (LWP 12325)]
[New Thread -1259349072 (LWP 12323)]
[New Thread -1248859216 (LWP 12322)]
[New Thread -1226204240 (LWP 12320)]
0x0081e402 in __kernel_vsyscall ()
#0  0x0081e402 in __kernel_vsyscall ()
#1  0x00c31fcb in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x077dfcfd in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  0x0805f64a in segv_redirect (sig=11) at main.c:424
#4  <signal handler called>
#5  0x0081e402 in __kernel_vsyscall ()
#6  0x00b7919c in poll () from /lib/libc.so.6
#7  0x001dbee8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#8  0x001dc383 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#9  0x0249e660 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#10 0x0805fac6 in main (argc=16, argv=0xbfb39194) at main.c:602

Thread 10 (Thread -1226204240 (LWP 12320)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c2e7b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0787c957 in e_msgport_wait (mp=0xaed23e78) at e-msgport.c:511
	msg = 
Thread 9 (Thread -1248859216 (LWP 12322)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c2e7b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0787c957 in e_msgport_wait (mp=0x8791328) at e-msgport.c:511
	msg = 
Thread 8 (Thread -1259349072 (LWP 12323)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c2e7b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0787c957 in e_msgport_wait (mp=0x8791328) at e-msgport.c:511
	msg = 
Thread 7 (Thread -1280328784 (LWP 12325)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c2e7b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0787c957 in e_msgport_wait (mp=0x8791328) at e-msgport.c:511
	msg = 
Thread 6 (Thread -1290818640 (LWP 12326)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c31fcb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00f946f0 in pipe_to_sa_full (msg=0x8861678, in=0x0, argv=0xb30fa0fc, 
    rv_err=0, wait_for_termination=1, output_buffer=0x0)
    at em-junk-filter.c:205
	maxfd = 
Thread 5 (Thread -1269838928 (LWP 12329)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c2e7b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0787c957 in e_msgport_wait (mp=0x8790e30) at e-msgport.c:511
	msg = 
Thread 4 (Thread -1311798352 (LWP 12330)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c2e7b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0787c957 in e_msgport_wait (mp=0x8787308) at e-msgport.c:511
	msg = 
Thread 3 (Thread -1301308496 (LWP 12333)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c2e7b6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0787c957 in e_msgport_wait (mp=0x8791328) at e-msgport.c:511
	msg = 
Thread 2 (Thread -1336996944 (LWP 12334)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c30e8e in __lll_mutex_lock_wait () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00c2dbb5 in _L_mutex_lock_36 () from /lib/libpthread.so.0
No symbol table info available.
#3  0x00c2f56f in pthread_kill () from /lib/libpthread.so.0
No symbol table info available.
#4  0x0805f63a in segv_redirect (sig=11) at main.c:433
No locals.
#5  <signal handler called>
No symbol table info available.
#6  0x06557f42 in send_queue_send (mm=0x9e0ccb8) at mail-ops.c:570
	sent_folder = (CamelFolder *) 0x87429d0
	uids = (GPtrArray *) 0x9c09cd4
	send_uids = (GPtrArray *) 0x9c09cc8
	ex = {id = CAMEL_EXCEPTION_NONE, desc = 0x0}
	i = 
Thread 1 (Thread -1209014608 (LWP 12315)):
#0  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00c31fcb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x077dfcfd in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  0x0805f64a in segv_redirect (sig=11) at main.c:424
No locals.
#4  <signal handler called>
No symbol table info available.
#5  0x0081e402 in __kernel_vsyscall ()
No symbol table info available.
#6  0x00b7919c in poll () from /lib/libc.so.6
No symbol table info available.
#7  0x001dbee8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x001dc383 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x0249e660 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#10 0x0805fac6 in main (argc=16, argv=0xbfb39194) at main.c:602
	fd = 

Looks like it is send_queue_mail as you say.
Comment 8 Paul F. Johnson 2005-08-25 09:05:08 EDT
Fixed in the current rawhide release. changing status accordingly.

Note You need to log in before you can comment on or make changes to this bug.