Bug 164493 - libicu has a dependency on old C++ libs
libicu has a dependency on old C++ libs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: icu (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On: 152495
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 07:29 EDT by Ignacio Vazquez-Abrams
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 12:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2005-07-28 07:29:52 EDT
libicu has a dependency on libstdc++.so.5 when the libstdc++ package in FC4
provides libstdc++.so.6. This causes a problem in C++ programs that also use libicu.
Comment 1 Michael Schwendt 2005-07-28 11:21:00 EDT
It was built with gcc32 deliberately. The only thing in Extras which depends on
libicu is mail-notification. What problems in C++ programs do you refer to?
Comment 2 Ignacio Vazquez-Abrams 2005-07-28 12:06:17 EDT
I was trying to build Firebird 2.0 Alpha 3 on FC4 against an external libicu
when it spat out a couple of messages like the following:

/usr/bin/ld: warning: libstdc++.so.5, needed by
/usr/lib/gcc/i386-redhat-linux/4.0.0/../../../libicuuc.so, may conflict with
libstdc++.so.6
Comment 3 Ville Skyttä 2005-07-31 11:33:12 EDT
Yep, and 3.4-d02 which I just committed to the devel branch (but will not 
request a build yet) seems to still suffer from the same problems, see bug 
152495 for the gcc32 reasoning. 
   
By the way, this package is up for grabs for anyone who wants it; I no longer  
actively use it.  (Cc'ing Thorsten who maintains mail-notification). 
http://fedoraproject.org/wiki/Extras/OrphanedPackages 
Comment 4 Thorsten Leemhuis 2005-09-13 12:22:28 EDT
Builds fine with gcc4 with
>export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"

Updated version for FC4 build (and mail-notification also). Will remove devel
branch because icu is in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.