Bug 164505 - Dynamically added devices not getting discovered by the host
Dynamically added devices not getting discovered by the host
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 08:40 EDT by Nitin Chandna
Modified: 2008-04-07 00:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 03:31:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nitin Chandna 2005-07-28 08:40:13 EDT
Description of problem:
Configured one JBOD and started the initiator on the host.
The device got discovered fine.
Now configured another JBOD on the iscsi target (MDS)
Configured all access details to be accessed by the iscsi host.
Still the device is not discovered by the host.

iSCSI Virtual Target Configuration: (1st Target got discovered - * indicates
this whereas 2nd target did not get discovered)

target: iqn.2004-04.com.cisco.cnitin-linux26-jbod-572d
  * Port WWN 22:00:00:04:cf:8c:57:2d
    Configured node
    No. of advertised interface: 1
      GigabitEthernet 2/1
    No. of initiators permitted: 2
      initiator 10.1.1.24/32 is permitted
      initiator 10.1.2.24/32 is permitted
    all initiator permit is disabled
    trespass support is  disabled
    revert to primary support is  disabled

target: iqn.2004-04.com.cisco.cnitin-linux26-jbod-567c

    Configured node
    No. of advertised interface: 1
      GigabitEthernet 2/1
    No. of initiators permitted: 1
      initiator 10.1.1.24/32 is permitted
    all initiator permit is disabled
    trespass support is  disabled
    revert to primary support is  disabled

[root@linux-2 linux-iscsi-3.6.3]# iscsi-ls -l
*******************************************************************************
        SFNet iSCSI Driver Version ... 3.6.3 (27-Jun-2005 )
*******************************************************************************
TARGET NAME             : iqn.2004-04.com.cisco.cnitin-linux26-jbod-572d
TARGET ALIAS            : 
HOST NO                 : 2 
BUS NO                  : 0 
TARGET ID               : 19 
TARGET ADDRESS          : 10.1.1.80:3260
SESSION STATUS          : ESTABLISHED AT Tue Jul 26 22:28:09 2005
NO. OF PORTALS          : 1 
PORTAL ADDRESS 1        : 10.1.1.80:3260,12416
SESSION ID              : ISID 00023d000001 TSIH 3080

DEVICE DETAILS :
-------------- 
LUN ID : 0
  Vendor: SEAGATE  Model: ST318452FC       Rev: 0004
  Type:   Direct-Access                    ANSI SCSI revision: 04
  page83 type3: 20000004cf8c572d
  page80: 3345563036523245303030303732343144393657
  Device: /dev/sdb
*******************************************************************************

/etc/iscsi.conf
DiscoveryAddress=10.1.1.80

GigE Interface 2/1 has the above IP address configured.


Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Always

Steps to Reproduce:
Same as above mentioned in the description.
1. Configured first target and that got discovered on a particular discovery
address.
2. Another target was configured on the same portal on the iscsi target.
3. Could not see any messages with respect to being notified about the new
target available to the host.
  
Actual results:
The newly added target was not visible to the host unless and until the driver
was restarted/reloaded

Expected results:
The driver should have been notified about the new target configured by the
iscsi target and host should have shown this device.

Additional info:
Comment 1 Mike Christie 2005-07-28 11:35:33 EDT
Is the new configuration supposed to be detected by the long lived discovery
session and sendtargets or some async event coming through the long lived
disocvery session. Since I cannot read about your discovery session AENs in the
RFC I am never completely sure which.
Comment 2 Smitha Narayanaswamy 2005-09-05 07:14:57 EDT
Async Event. There is no async event coming up from the target side. This is not
a bug in the driver.

Note You need to log in before you can comment on or make changes to this bug.