Bug 164506 - Bringing down GiGE connection does not let stop IO
Bringing down GiGE connection does not let stop IO
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 08:45 EDT by Nitin Chandna
Modified: 2008-04-07 00:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 03:30:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nitin Chandna 2005-07-28 08:45:06 EDT
Description of problem:
Executed raw IO as follows after configuring a JBOD:
[root@linux-2 tools]# dd if=/dev/zero of=/dev/sdb bs=512
..

Now brought down the interface GiGE 2/1.
Login into the target was continuously getting retried. 
Ctrl+C in the IO window is not effective.
There is no way to stop the IO.
README specifies a variable CONNFAILTIMEOUT has been specified as 30sec for
pending IOs to come out.
But still this does not seem to come out at all.
This did not come out for 30 minutes and I had to restart the interface on iSCSI
Target.


Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Most of the time

Steps to Reproduce:
1. Executed raw IO as follows after configuring a JBOD:
[root@linux-2 tools]# dd if=/dev/zero of=/dev/sdb bs=512
..

2. Now brought down the interface GiGE 2/1.
3. Login into the target was continuously getting retried. 
4. Ctrl+C in the IO window is not effective.
5. There is no way to stop the IO.
6. README specifies a variable CONNFAILTIMEOUT has been specified as 30sec for
pending IOs to come out.
7. But still this does not seem to come out at all.
8. This did not come out for 30 minutes and I had to restart the interface on
iSCSI Target.
9. The value for the mentioned variable has been specified to change in rc.iscsi
file, but the path to rc.iscsi file is not been specified.

Actual results:
No way to stop the raw IO, if the connection to GiGE is dropped, with Ctrl+C.

Expected results:
After the CONNFAILTIMEOUT value, the IOs should have stopped with Ctrl+C

Additional info:
Comment 1 Mike Christie 2005-07-28 11:52:03 EDT
Which version of the driver is this and in what section does it state
CONNFAILTIMEOUT=30 secs. I am looking at the sourceforge versions and RHEL and
it looks like the default is 0 secs. Did you override this and set it to 30?

This secstion
        ConnFailTimeout and DiskCommandTimeout are set to 30 and 5 respectively
        in rc.iscsi during stop of the driver. This is done so as to prevent
        a hang that can be caused because of unresponsive targets. You can
        change these values by setting CONNFAILTIMEOUT and DISKCOMMANDTIMEOUT
        respectively in the rc.iscsi file.

states that ConnFailTimeout=30 secs when you run the rc script only. The rc
script is the typical /etc/ rc script. Run "/etc/init.d/iscsi stop"
Comment 2 Smitha Narayanaswamy 2005-08-10 01:28:30 EDT
The ConnFailTimeout is set to 30 seconds only during shutdown. There is no
default value set for a connection failure. It is set to zero, which makes the
ConnFailTimeout infinite. This bug can be closed as it is not a bug.

Note You need to log in before you can comment on or make changes to this bug.