Bug 164507 - Dependency issues with libcdio
Dependency issues with libcdio
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libcdio (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-28 08:49 EDT by Scott Glaser
Modified: 2012-09-15 00:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 08:54:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Glaser 2005-07-28 08:49:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When attempting to urn yum update there are several dependancy issues with libcdio.  Errors are posted below:


yum update
Setting up Update Process
Setting up repositories
livna                     100% |=========================|  903 B    00:00
freetype-bci              100% |=========================|  951 B    00:00
updates-released          100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package clamav-lib.x86_64 0:0.86.2-2.fc4 set to be updated
---> Package id3lib.x86_64 0:3.8.3-12.fc4 set to be updated
---> Package clamav.x86_64 0:0.86.2-2.fc4 set to be updated
---> Package clamav-data.x86_64 0:0.86.2-2.fc4 set to be updated
---> Package libcdio.x86_64 0:0.75-3.fc4 set to be updated
---> Package libcddb.x86_64 0:1.2.0-2.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libcdio.so.5(CDIO_5)(64bit) for package: vcdimager
--> Processing Dependency: libcdio.so.5()(64bit) for package: xine-lib
--> Processing Dependency: libcdio.so.5()(64bit) for package: vcdimager
--> Processing Dependency: libcdio.so.5(CDIO_5)(64bit) for package: xine-lib
--> Finished Dependency Resolution
Error: Missing Dependency: libcdio.so.5(CDIO_5)(64bit) is needed by package vcdimager
Error: Missing Dependency: libcdio.so.5()(64bit) is needed by package xine-lib
Error: Missing Dependency: libcdio.so.5()(64bit) is needed by package vcdimager
Error: Missing Dependency: libcdio.so.5(CDIO_5)(64bit) is needed by package xine-lib



Version-Release number of selected component (if applicable):
libcdio-0.75-3.fc4   Kernel 2.6.12-1.1398_FC4 x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have xine-lib installed.
2. Run command 'yum update'
3.
  

Actual Results:  --> Running transaction check
--> Processing Dependency: libcdio.so.5(CDIO_5)(64bit) for package: vcdimager
--> Processing Dependency: libcdio.so.5()(64bit) for package: xine-lib
--> Processing Dependency: libcdio.so.5()(64bit) for package: vcdimager
--> Processing Dependency: libcdio.so.5(CDIO_5)(64bit) for package: xine-lib
--> Finished Dependency Resolution
Error: Missing Dependency: libcdio.so.5(CDIO_5)(64bit) is needed by package vcdimager
Error: Missing Dependency: libcdio.so.5()(64bit) is needed by package xine-lib
Error: Missing Dependency: libcdio.so.5()(64bit) is needed by package vcdimager
Error: Missing Dependency: libcdio.so.5(CDIO_5)(64bit) is needed by package xine-lib


Expected Results:  The packages that have updates available should be updated.

Additional info:
Comment 1 Adrian Reber 2005-07-28 08:54:48 EDT
xine-lib and vcdimager are not part of Fedora Extras those are packages from a
third party repository. (I know that these packages are currently rebuilt)

There is already a bugzilla entry at the repository for this bug.
Comment 2 Scott Glaser 2005-07-28 09:01:11 EDT
Adrian, I was just reading 164270 and changing it to not a bug as you did.  Thanks

Note You need to log in before you can comment on or make changes to this bug.